1

We have a Windows 2016 server where we want to add Single Sign-On, but when I add the server to the local GPO of my computer and try to log on, I get a screen with an empty user field.
I have tried both with windows 10 and windows 7 with the same results, for testing user I am using a Domain Admin Account.
I have also tried to add one of our windows 2012 servers to SSO with no issues.

I would like to know if anyone knows how to fix this issue?
Any help is greatly appreciated.

0

I solved the issue myself.

At some point I made a change in the registry, it screwed with the NLA settings for the remote desktop.

I made sure that the registry looks like this, and my problem was solved.

HKLM\System\CurrentControlSet\Control\Terminal Server\fDenyTSConnections = 0
HKLM\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\UserAuthentication = 1
HKLM\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\SecurityLayer = 1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.