I was trying to deploy CentOS from PXE with an install directory extracted from latest iso (1611). Install failed (with or without kickstart) because of microcode_ctl package, after some researches I found out there is updated rpm that fix the problem.

My problem is : I don't know how to update the rpm in my install folder and keep CentOS installer work

Here is what I tried based on my research :

  • Download the Packages and repodata folders and try to update with

    createrepo ./Packages

    and update repodata on server with new files, didn't work because no group

  • Same but with groups from the *x86_64-comps.xml file

    createrepo -dpo . ./Packages -g /path/to/*-x86_64-comps.xml
  • Same with --checksum sha parameter

For the 2 last methods I have "Error populating transaction" and "No more mirrors to try" errors at the first package it try to install.

Obviously it means I did something wrong and the installer can't locate the packages anymore, but I don't find what to do. Any help or hints would be appreciated, Thanks.


I would not mess with the initial installation tree. Instead I would provide a second yum repository for important updates/drivers and use the following parameter in the kickstart file:

repo --name=repoid [--baseurl=<url>|--mirrorlist=url] [options]

microcode_ctl issues are often due to unsupported server hardware (either too old, or not yet certified for the given CentOS/RHEL release).

Minimal kickstart example:

url --url=http://mirror.centos.org/centos/7/os/x86_64/
repo --name=updates--baseurl=http://mirror.centos.org/centos/7/updates/x86_64/

lang en_US.UTF-8
keyboard de
network --onboot yes --device eth0 --bootproto dhcp --ipv6 auto
rootpw secret
firewall --service=ssh
authconfig --enableshadow --passalgo=sha512
selinux --enforcing
timezone --utc Europe/Berlin
bootloader --location=mbr
clearpart --all --initlabel
firstboot --disabled

  • Not sure how to do this properly, is there a way to use this : http://mirror.centos.org/centos/7/updates/x86_64/ ? – Wddysr Jun 23 '17 at 9:40
  • Thanks for your update, but I still don't understand what's wrong with my config : https://pastebin.com/3bvHC6hS (It says that installation source is not setup) – Wddysr Jun 23 '17 at 13:17
  • Hum... Somebody gave me a method to bypass the crash during the install : Retry the install until it works. And it did work after between 10 to 20 install... Thank you anyway ! – Wddysr Jun 23 '17 at 14:22

I solved it by setting up the network and host name at the bottom of the installation summary page. it was a pre-requisite (not automatic) and I didn't notice the obvious Alert at the bottom of the page!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.