0

I have a host server that has 2 IP's assigned to it, one global (78.129.x.x) and one local (192.168.61.20). I also have a virtual machine in HyperV with the following settings:

The settings of the HyperV virtual machine

So what I'm trying to achieve is a local network where I can setup VMs with IP range of 192.168.61.x, hence I've given the VM 192.168.61.21 - which works and it is pingable and RDP-able.

However, I have no connection to the internet. I thought that because my HyperV switch (to the network adapter on the main server) had the 192.168.60.20 IP (which is the gateway on the VM), it would have access to the public internet - however this is not the case.

What do I have to do to allow the VM with the local IP to access the public internet, ie. Google.com?

Are my settings incorrect? Note I'm a little new to all of this :)

Any help appreciated.

0

The virtual switch is a physical conduit to the physical network. It doesn't provide routing for the virtual machines. You'll need to configure the virtual machines with the appropriate ip address settings, including a valid default gateway address, in order to reach the internet.

1
  • So that would involve giving the VM the public IP of the host server, and then setting a local IP as an additional? I was hoping to only achieve a local address
    – a--
    Jun 22 '17 at 18:15
0

what you will need to do is install Remote access on the HyperV host server and then configure NAT. That way your VMs can keep their Private IP addresses and still connect to the internet through the NAT services.

right now you are using 192.168.60.20 as the gateway for your Vms but the host has no idea shat you want to do with the traffic.

You will also need to address name resolution, where is your DNS server?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.