0

My rootserver's power supply died the day before and the hoster had to replace it. Since then, the server does not boot correctly anymore. Because of the sudden powerloss, it starts right in some kind of maintenance mode.

The hoster is not able to further help me and sent me the screenshot.

enter image description here I can login to the server using a remote "recovery" image (I have no access to KVM, only the hoster does) which I think is some kind of rescue image that allows me to mount my original sda (which I can do successfully).

How can I turn off the maintenance mode and boot into default mode using the rescue image? When I enter any systemctl command, it does not apply to my real system but apparently to the resuce image in RAM. I think I have to change a file on the mounted disc or something.

Please guide me out of this :-(

Update:

The support team sent me another screenshot: enter image description here

  • 1
    Slightly above what's on the screen it should say something about what caused it to enter the emergency shell. Can you get a new screenshot after having the hoster press shift-pageup to scroll back? – Tollef Fog Heen Jun 22 '17 at 19:31
  • That maintenance mode usually has to do with filesystems not found, or were unmounted improperly (which may be your case, since the server lost power suddenly). As @TollefFogHeen said, I would try to guess the error from output that came before what you are showing. Also, check if you have a chroot utility on that rescue image you are booting. For instance, Hetzner has chroot_prepare (which mounts /dev, /sys, et. al.) and chroot, which allow to "get into" your server after you mounted its root filesystem. There you can perpaps run the recommended journalctl -xb and gather info. – Pablo Jun 23 '17 at 3:14
  • No success yet. Is there a file where I can set boot_in_emergecy_mode=false or something? – Daniel W. Jun 23 '17 at 7:42
  • @TollefFogHeen They sent me a screenshot but I don't know how this error did not come up earlier or don't know how to solve it-- – Daniel W. Jun 23 '17 at 8:41
  • It's right in your screenshot. Type "systemctl default" to try again to boot into default mode". Before doing this in your chroot environment you should run fdisk on your disks, check logs etc. – Gerald Schneider Jun 23 '17 at 9:21
0

Problem solved..

the second SSD in the server is damaged or not properly connected (thus the error A job is still running... for sdb).

I can mount sda but sdb is not in /dev.

  • Did fixing the SSD disable the maintainance mode automatically or did you have to do something else to disable it? – Gerald Schneider Jun 23 '17 at 12:19
  • @GeraldSchneider No action was needed. They plugged the cable in correctly and it did work after a restart. – Daniel W. Jun 23 '17 at 18:22
-1

If the server turn into recovery mode thats mean you have a bug somewhere on the boot.

Here is a common problem with some hardware.

Just boot from a CD and install driver-nonfree package to fix the boot. Maybe chroot can help you to make things work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.