1

I've written my own simple munin-node implementation, but cannot get it to show on an master (2.0.33-1) in munin-cgi-html.

munin.conf configuration:

[uberlamp3]
    address 192.167.0.21
    use_node_name yes
    port 19270

I monitor conversation between the master and the node and see see that node is asked for:

1: cap (I return empty caps)

2: list (I return the only plugin - temp)

3: config temp. I return:

graph_args --title "Lamp Temperatures"
graph_category Temperatures
temp.label temp
.

4: fetch temp. I return:

temp.value 47.3

5: quit - I drop connection. No errors in munin-update.log

All that is processed normally on munin-update. No errors in munin-update.log. Corresponding rrd file is created and updated with correct values (checked with rrdtool). But munin-cgi-html never show this new node in generated HTML.

munin-update.log:

2017/06/23 07:40:01 [INFO] starting work in 9170 for uberlamp3/192.167.0.21:19270.
2017/06/23 07:40:01 [INFO] node uberlamp3 advertised itself as uberlamp.14.by instead.
2017/06/23 07:40:01 [INFO]: Munin-update finished for node uberlamp3;uberlamp3 (0.33 sec)
2017/06/23 07:40:06 [INFO] Reaping Munin::Master::UpdateWorker<uberlamp3;uberlamp3>.  Exit value/signal: 0/0

Few more observations:

1) htmlconf.storable - contains references to uberlamp3 node

2) I've tried to add one more native munin-node, which added without issues - and after update shows in html/graphs. uberlamp3 though still not showing.

Any suggestions?

Munin version: 2.0.33-1 Ubuntu Version: tried 16.10 and 17.04

0

" node uberlamp3 advertised itself as uberlamp.14.by instead."

What happens if you type "hostname" on the client?

Have you checked munin client configuration?

  • Tried that. It appears these hostnames mismatches are common thing - happens all the time. The only effect is the name of the node on the web page. I tried to make it match - there were no difference. – BarsMonster Jun 28 '17 at 13:05
  • And of course I had no client configuration - as I had my own custom client. – BarsMonster Jun 28 '17 at 13:05
0

Apparently, munin is very sensitive to graph configuration returned by node.

After I copy-pasted config response from native nodes (using telnet, then list, then "config uptime" for example), it started working and showed all the old data it captured.

graph_title Temperatures
graph_args --base 1000 -l 0
graph_vlabel °C
graph_category system
temp.draw AREA
temp.label temp
.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.