2

I'm upgrading an old server to become a new server / compute node.

System description: six SATA disks, each partitioned with a ~200MB boot partition, ~4GB swap partition, a ~200GB RAID1 across all six, a ~2.5TB RAID6 partition across all six, and a ~7.5TB RAID6 partition across all six (all raids software / mdadm). The root partition is fully backed up and wiped, but I don't want to have to wipe the RAID6s. I'm looking to keep roughly the same config (ext4), although might prefer to get rid of the boot partitions (they're getting to be too small for modern installs anyway) for more swap.

"Progress" thusfar:

  • First attempted just to boot the old Linux (something like Fedora 13). Got to the Grub boot screen, tried to boot the kernel, but only got through one line before locking up.

  • Decided that the old system couldn't deal with modern hardware and that it was time to upgrade to Fedora 25 or 26B (my Linux experience is with Fedora, I prefer not to switch distros). Both 25 and 26B behave basically the same. When it boots into the GUI mouse and keyboard performance are terrible. Hugely laggy and jumpy. 1 in 3 keypresses are interpreted as about 20 keypresses. Typing almost anything of length (such as "/boot/efi") takes 5-10 minutes. The lag doesn't occur in console mode.

  • When trying to install in legacy boot mode, half the time the install segfaults. The other half of the time, grub fails with a generic message ("boot loader install failed"). Running grub2-install from the command line yields "warning: this GPT partition label contains no BIOS Root Partition" and "error: embedding is not possible, but this is required for cross-disk install". The failed grub install occurs whether I choose to include a boot partition or just the RAID1 root partition.

  • When trying to install in UEFI boot mode (thus including a /boot/efi partition), installation completes, but the system does not boot. I just get a grub prompt on one of the drives, perhaps even from the old grub install of the previous system. I can't find a way to get anything to boot from it, no matter what combination of "root (hdX,Y)" I choose for all values of X and Y.

  • When trying to use anaconda in text mode to avoid the mouse/keyboard lag hell, the installation source always yields "Error setting up software source" - even if I point it straight to an ISO, or choose the DVD that it's installing from. Strangely the GUI never complaints about this.

  • It'd be nice to be able to try to do this remotely or to do a net install, except that the network driver doesn't work - it says no link. I tested the ethernet cable with my laptop and it's fine. The motherboard lights up when it's connected, and there are occasional flashes from it on the router side. It's an Intel 82599 card, and googling reveals that to run it one should install the ixgbe module, but the Fedora Live installer doesn't appear to be set up to build kernel modules.

It's going on two days now. Any ideas where I should focus my efforts?

Hardware: DA0S2MMB8B0 motherboard, dual xeon E5-2660, 64GB ram (8x4GB), no add-on cards, standard USB keyboard and mouse that have never been problematic, CD/DVD drive connected to one of the six SATA ports, the other SATA drives connected to the other 5 SATA ports plus one to a SAS port (they all detect and seem to operate fine, and I can mount the raid arrays with no problem). Keyboard and mouse plugged into the back 2 USB ports; the onboard USB headers for the front ports don't seem to work - but again, there's no problem in text mode, and other USB devices work just fine.

  • Tell us about the hardware you're using. – EEAA Jun 23 '17 at 22:35
  • Please edit your question and include that information there, not in comments. – EEAA Jun 23 '17 at 23:11
  • Done. Any suggestions on what to try? – KarenRei Jun 23 '17 at 23:24
  • Just to confirm, you can boot with a livecd/livedvd/liveusb system and mount your raid volumes with no problem yes? IIRC from long ago a solution involved booting from a live image and chrooting and writing grub multiple times, once to each drive/partition, but I'm also thinking it was for using a software raid as your / ... – ivanivan Jun 24 '17 at 1:29
  • 1
    Well, here's something: lag hell goes away when I choose "basic graphics mode" on the install CD. Still doesn't help with the boot problems, but, hey, I'll take it. – KarenRei Jun 24 '17 at 13:46
0

Well, while I never got it to work in UEFI, I got it to work in legacy, and thatðs good enough. I had to pass the "inst.gpt" option to anaconda on boot. add 2MB grub boot partitions as sdX1 within anaconda (not after). Anaconda still crashed three times during the install, but on the fourth it went through.

I still don't have net access (been working on that), but whatever.... if I can't resolve it I can use an addon card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.