0

I want to monitoring my Dell's iDRAC with Zabbix 3.0 (on Centos7). But it does not load the custom MIB. I tried every solutions what I found, but its still do nothing.

Zabbix error:

SNMP agent item "sysUpTime" on host "host_name" failed: first network error,

I tried to put "mibs +ALL" to snmpd.conf. (and etc)

I can run this command:

snmpwalk -v2c -c Gate1 -O e xxx.xxx.xxx.xx

But its dont load the Dell's MIB.

Edit:

The zabbix cant connect to iDRAC over SNMP.

Error: SNMP agent item "sysUpTime" on host "Gate1_iDRAC" failed: first network error, wait for 15 seconds

I selected "Templates SNMP Devices", but the other hosts are still working fine with SNMP.

Edit2:

Okay, i had to define in macros the {$SNMP_COMMUNITY}, and now, its working w/o DELL's MIB.

The END

The macro has solved the problem, so everything work fine. This is my fault.

(Reallly sorry for my English)

  • That is unlikely to be related to MIBs. Verify that the port and community are correctly specified. Note that the community can be specified for each item - you probably want to use usermacro for that. – Richlv Jun 26 '17 at 15:16
  • The port and community are working fine. I can run query with defaults MIBs. (IP-MIB, TCP-MIB, SNMPv2-MIB, etc) – G3ph4z Jun 26 '17 at 15:26
0

Fill the {$SNMP_COMMUNITY} macro at the host settings.

  • Slightly disappointed that you responded to my comment about the community possibly being the problem with "The port and community are working fine" and then configuring the community. – Richlv Jun 26 '17 at 19:27
  • Im really sorry, I misunderstood. But thank you very much for your help. – G3ph4z Jun 26 '17 at 19:57
0

mib2zabbix

Perl script will generate a Zabbix v3 Template in XML format from an OID tree in a SNMP MIB file.

Read more here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.