1

I run my own HTTP, SMTP and DNS server on a local box. I have LAMP, Postfix and BIND9 on Ubuntu to be exact. Everything was great, except that the e-mail which was sent from my mail server often got rejected by the remote SMTP servers due to lack of correct rDNS (PTR) record (basically, I never bothered to ask my ISP to update it for me, so it was a generic one). So finally I did it. My ISP updated rDNS record for an IP address that I use for all the servers (they all are together on one physical computer). So an IP resolves to the hostname of my mail server, which is:

mail.mysite.com

When I do reverse DNS lookup with "nslookup" command, by FIRST choosing Google's DNS server (8.8.8.8), then I get the correct hostname. But when I use my own DNS server, I get servfail error. Right now every server of mine seems to be working correctly. I haven't seen anything unusual or some problem with anything. So should I just wait for the DNS propagation (my ISP updated an IP about 6 hrs. ago) OR is there anything I personally should update either in my DNS server's settings or something else maybe?

0

Okay, so I solved this like so:

Let's say that my IP address would be 46.249.xx.yy In file named.conf.local I wrote this, regarding reverse DNS zone:

zone "xx.249.46.in-addr.arpa" {
type master;
file "/etc/bind/zones/db.46.249.xx";
};

In file db.46.249.xx, which is in "zones" directory I did this:

;
; BIND reverse data file for local loopback interface
;
$TTL    604800
@    IN    SOA    ns1.xxxxxxxx.com. director.xxxxxxxx.com. (
              2        ; Serial
         604800        ; Refresh
          86400        ; Retry
        2419200        ; Expire
         604800 )    ; Negative Cache TTL
;

@      IN      NS     ns1.
yy     IN     PTR     ns1.xxxxxxxxxx.com.
yy     IN     PTR     mail.xxxxxxxxx.com.

Now when I restart BIND, I don't get any errors anymore in debug.log file and when I run this:

nslookup 46.249.xx.yy

then I get 2 answers back:

ns1.xxxxxxxxx.com

and

mail.xxxxxxxx.com

And when I run the check:

named-checkzone xxxxxxxxx.com /etc/bind/zones/db.46.249.xx

I get OK.

P.S. In short, my reverse DNS zone file was all messed up and it really had nothing to do with my ISP updating my PTR record for my static IP that they own.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.