3

I am currently building a new server for Citrix XenApp on Win 2k16, and we're being prompted with the box below:

https://i.stack.imgur.com/uu4yt.png

This is happening per user, so can be quite tedious. And the popup doesn't actually say the type of file it's trying to open which is not helpful as well. When we specify it to open in IE, the prompt does not return for that user upon any subsequent login, but opens IE every time the user logs in.

Citrix XenApp is currently installed, so this may have something to do with it.

Things we've tried to prevent this happening:

  • We've booted the machine in diagnostic mode, so only the basic drivers / services are loaded, and the popup still occurs, which leads me to believe that it is a Windows service that is causing this.
  • We've exported the associations using assoc > machineAssoc.txt for a user that has the prompt, then, have specified it to open in IE, and ran the command again (with a different filename). There was no difference in these two files.
  • 1
    Take a look with autoruns. Could also be something in startup folder, GP login item/script. – jscott Jun 28 '17 at 23:04
  • Thanks @jscott, we are looking into this now. Looks like an excellent program. – Aaron Fahey Jun 28 '17 at 23:12
  • when you associate the unknown element with IE and IE opens at all logins, is it opening a specific file? or is it just an empty IE window with the default homepage? – Ale Jun 29 '17 at 0:02
  • it's just opening the Microsoft news homepage, no specific file at all – Aaron Fahey Jun 29 '17 at 0:04
3

We've found a solution finally.

The issue is not only with Windows Server 2k16, but also with Windows 10 in general.

1) To remove the annoying box that pops up, we exported the Default Associations file, and deployed it via Group Policy, note the default associations file only had Internet Protocols / web type files in it, and all pointed to Internet Explorer.

2) To stop Internet Explorer opening on boot, we stumbled across this article, which suggested we deploy this registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing = 0

This sorted our issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.