Server Environment: Ubuntu 16.04 running in Azure Firewall allowing ports 64000-65000, also 21 and, just to be sure, 989-990 running pure-ftpd, config follows in /etc/pure-ftpd/conf ForcePassiveIP contains external IP PassivePortRange contains 64000 65000

i'm authenticating with PureDB

If I connect from our office IP which is whitelisted in Azure's firewall, it connects just fine. When I test connection from external IP, ie through my cell, it errors out.

Status: Connecting to the.ip.addr.ess:21...
Status: Connection established, waiting for welcome message...
Trace:  CFtpControlSocket::OnReceive()
Response:   220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Trace:  CFtpControlSocket::OnReceive()
Response:   220-You are user number 2 of 50 allowed.
Response:   220-Local time is now 14:37. Server port: 21.
Response:   220-This is a private system - No anonymous login
Response:   220-IPv6 connections are also welcome on this server.
Response:   220 You will be disconnected after 15 minutes of inactivity.
Trace:  CFtpControlSocket::SendNextCommand()
Command:    AUTH TLS
Trace:  CFtpControlSocket::OnReceive()
Response:   234 AUTH TLS OK.
Status: Initializing TLS...
Trace:  CTlsSocket::Handshake()
Trace:  CTlsSocket::ContinueHandshake()
Trace:  TLS handshake: About to send CLIENT HELLO
Trace:  TLS handshake: Sent CLIENT HELLO
Trace:  CTlsSocket::OnSend()
Trace:  CTlsSocket::OnRead()
Trace:  CTlsSocket::ContinueHandshake()
Error:  Connection timed out after 20 seconds of inactivity
Trace:  CControlSocket::DoClose(2050)
Trace:  CFtpControlSocket::ResetOperation(2114)
Trace:  CControlSocket::ResetOperation(2114)
Error:  Could not connect to server
Trace:  CFileZillaEnginePrivate::ResetOperation(2114)

I have also set the port range in Filezilla to match. I have tried both Require explicit TLS and "use if available"

Can anyone offer a fix or explanation, or even a hint as to what's going on here?

Thanks in advance!!

  • The firewall on Azure - it's set to only permit connections via certain IPs as well as ports, right? Or is it set to permit every connection from the Internet over those ports? – Thomas Ward Jun 30 '17 at 14:54
  • Those ports are set to accept connections from any source. Then there are also rules to allow all ports from one or two IPs, ie my office. When at office, it works, when not from office IP, it doesn't. Which SEEMS to indicate I haven't opened enough ports, but I'm at a loss as to what might be missing after three days of research and tweaking. – Bruce Jun 30 '17 at 14:57
  • Without seeing the firewall rules, I can't say for certain whether that's the case or not. Ideally though you aren't going to be opening FTP or FTPS to the 'world' though, and going to have a small subset of permitted IPs. (Or, just use SFTP, which ships as part of the OpenSSH Server package in Ubuntu, and lets you use SSH as the auth/transfer/encryption method) It does sound like a firewall configuration issue, but again without more config information and more firewall config information here, it's hard to point exactly at one issue being the problem. – Thomas Ward Jun 30 '17 at 15:00
  • Hi Thomas. we WERE using sftp via vsftp, but the problem is that that also allows direct ssh access, and we don't want these particular clients just roaming all over this server. As to Firewall rules, I don't know if you've used Azure, but afaik it's pretty straightforward. The rules are numbered, and it shows Source and Destination. For those rules, both show ANY. Unfortunately, even with VerboseLog enabled in pure-ftpd, not much gets logged that is relevant. – Bruce Jun 30 '17 at 15:09
  • It is trivial to restrict users to sftp only, chrooted, and with ssh shell access disabled. – EEAA Jul 1 '17 at 4:57

Ok, so, after extensive go-round with the Azure support team, it seems that pure-ftpd was the problem. It simply wasn't paying attention to several directives, including which passive ports it was supposed to be using. I redid the whole thing with vsftpd again, and it seems to have worked. For the moment I have given up on virtual users, for time's sake. Below is what I did:

This guide shows how to have vsftpd chroot only certain users.

sudo apt-get install vsftpd ftp

vi /etc/vsftpd.conf


# Example config file /etc/vsftpd.conf
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
# Run standalone?  vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
pasv_address=EXTERNAL IP of your server
# This directive enables listening on IPv6 sockets. By default, listening
# on the IPv6 "any" address (::) will accept connections from both IPv6
# and IPv4 clients. It is not necessary to listen on *both* IPv4 and IPv6
# sockets. If you want that (perhaps because you want to listen on specific
# addresses) then you must run two copies of vsftpd with two configuration
# files.
# Allow anonymous FTP? (Disabled by default).
# Uncomment this to allow local users to log in.
# Uncomment this to enable any form of FTP write command.
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
# If enabled, vsftpd will display directory listings with the time
# in  your  local  time  zone.  The default is to display GMT. The
# times returned by the MDTM FTP command are also affected by this
# option.
# Activate logging of uploads/downloads.
# Make sure PORT transfer connections originate from port 20 (ftp-data).
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
# You may override where the log file goes if you like. The default is shown
# below.
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
# You may change the default value for timing out an idle session.
# You may change the default value for timing out a data connection.
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
# (default follows)
# You may restrict local users to their home directories.  See the FAQ for
# the possible risks in this before using chroot_local_user or
# chroot_list_enable below.
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
# (default follows)
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
# Customization
# Some of vsftpd's settings don't fit the filesystem layout by
# default.
# This option should be the name of a directory which is empty.  Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
# This string is the name of the PAM service vsftpd will use.
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.
# rsa_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
# rsa_private_key_file=/etc/ssl/private/ssl-cert-snakeoil.key


# Uncomment this to indicate that vsftpd use a utf8 filesystem.


Note that you’ll need to change the IP address in here for your server’s external IP

sudo su

mkdir -p /etc/pki/tls/certs/ cd /etc/pki/tls/certs/

openssl req -newkey rsa:2048 -new -nodes -x509 -days 3650 -keyout key.pem -out cert.pem

Make sure you specify the correct FQDN for your server.

chown 600 *

Add your ftp user:


usermod -s /bin/false

vi /etc/shells

Add /bin/false as the last line if it’s not already in the file

cd /home

Modify the directory so it can be written to if necessary

Make sure you’ve allowed ports 13000-13100 (or whatever range you choose) in firewall for that server (both server and azure)

sudo vi /etc/vsftpd.chroot_list

In there, enter, one per line, the users that need to be chrooted

service vsftpd restart

service vsftpd status ##To make sure all is running correctly

I hope this helps someone. I documented this after the first go thru worked, and then applied it to a second server that needed it, and it worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.