1

As the title implies, I am getting this error whenever I am trying to run newaliases. First, a bit of explanation. I was trying to do an upgrade on my debian server from jessie to stretch, and I almost got all packages upgraded, minus postfix and postfix-mysql. Also, in the upgrade mysql was replaced with mariadb. I'm not sure if this is problematic, but whenever I try to re-run the upgrade to re-configure postfix packages, I get the following:

Setting up postfix (3.1.4-7) ...

Postfix (main.cf) configuration was not changed.  If you need to make 
changes,
edit /etc/postfix/main.cf (and others) as needed.  To view Postfix
configuration values, see postconf(1).

After modifying main.cf, be sure to run 'service postfix reload'.

Running newaliases
postalias: fatal: unsupported dictionary type: mysql does not support bulk-mode creation.
dpkg: error processing package postfix (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of postfix-mysql:
 postfix-mysql depends on postfix (= 3.1.4-7); however:
  Package postfix is not configured yet.

dpkg: error processing package postfix-mysql (--configure):
 dependency problems - leaving unconfigured

I'm not sure what's causing the issue and I'm not able to reboot until the packages are resolved due to other unrelated reasons on the system currently.

  • I had a jessie system configured for postfix+mysql+dovecot mostly based on the instructions at workaround.org and it dist-upgraded to stretch with no issue. To fix your issue, perhaps uncomment the mysql driver lines/mappings in your main.cf and then let postfix reconfigure, then postfix-mysql should do it, and then go back and re-enable the mysql portion of the main.cf file. – ivanivan Jul 2 '17 at 16:09
  • I'm probably not going to take immediate action to resolve this since I'm attempting to have as little downtime as possible and just seeking out the cause of the issue for now. After I get a better understanding, I will go ahead and try to resolve it knowing I can get back online quickly. Right now my solution is just to migrate server's, and duplicate configuration file edits (not replacing the new one's, just updating the values). – cellsheet Jul 3 '17 at 2:03
1

I had exactly the same problem and solved it like this:

  • edit /etc/postfix/main.cf and comment out all lines containing mysql: for aliases (for instance # alias_maps = mysql:/etc/postfix/mysql-virtual-alias-maps.cf)
  • run service postfix reload to take it into account
  • re-run the upgrade to re-configure postfix packages, this time it should work
  • re-edit main.cf to remove the comment and reload the postfix service as above
  • Thank you for the solution, a friend of mine was able to figure out the root issue of it by uninstalling and then re-installing the two packages in a different order as it was a recursive apt dependency issue it seems like. Unfortunately I cannot test the validity of this answer, but if it is valid, then you deserve up-votes. – cellsheet Nov 2 '17 at 13:07
  • Be careful about re-adding formerly commented options, those might be the problem because things fail. I ran into that problem with postfix-pcre and simply needed to remove alias_database entirely, which makes sense, as with PCRE there is no additional database. Using alias_maps = pcre:/etc/postfix/aliases seems to be enough and doesn't seem to trigger the error. – Thorsten Schöning Dec 26 '19 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.