2

I made a HUGE mistake a while ago and installed/enabled the remi repo to upgrade php. This has caused issues in our CRM package. I would like to be able to return to the previously installed php from atomic. I have tried executing:

yum remove --nodeps php.x86_64 php-cli.x86_64 php-common.x86_64 php-devel.x86_64 php-gd.x86_64 php-imap.x86_64 php-ldap.x86_64 php-mbstring.x86_64 php-mcrypt.x86_64 php-mysqlnd.x86_64 php-pdo.x86_64 php-pear.noarch php-pecl-jsonc.x86_64 php-pecl-jsonc-devel.x86_64 php-pecl-zip.x86_64 php-process.x86_64 php-tidy.x86_64 php-xml.x86_64

This comes back with dependencies to be removed (which I assume will break Plesk):

    Removing for dependencies:
 php-ioncube-loader
                 x86_64 1:4.7.1-4.el6.art             @atomic             7.3 M
 psa-horde       noarch 5.2.6-cos6.build1205150821.14 @PLESK_12_5_30-dist  66 M
 psa-imp         noarch 6.2.9-cos6.build1205150819.14 @PLESK_12_5_30-dist  18 M
 psa-ingo        noarch 3.2.5-cos6.build1205150819.14 @PLESK_12_5_30-dist 4.5 M
 psa-kronolith   noarch 4.2.8-cos6.build1205150819.14 @PLESK_12_5_30-dist 8.8 M
 psa-mnemo       noarch 4.2.6-cos6.build1205150819.14 @PLESK_12_5_30-dist 3.3 M
 psa-passwd      noarch 5.0.2-cos6.build1205150819.14 @PLESK_12_5_30-dist 2.9 M
 psa-php5-configurator
                 x86_64 1.7.0-cos6.build1205150820.19 @PLESK_12_5_30-dist  54 k
 psa-turba       noarch 4.2.7-cos6.build1205150819.14 @PLESK_12_5_30-dist 6.2 M

I have researched alternative methods to remove these packages including the --nodeps option in rpm. But I'm not willing to further break the system. I have tried downgrade, reinstall and further researched yum shell. I'm at a loss.

Any assistance would be appreciated.

  • I have huge doubts this is related to "remi" repository, rather to version choosen. BTW, plesk server sARE NOT centos (too much altered) – Remi Collet Jul 3 '17 at 15:20
1

You could use yum history command. It shows your couple last yum commands and you cold revert command when installed PHP from Remi repo by command yum history undo <ID>.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.