0

So I'm totally at a loss for what's going on here. I logged into my GCP instance the other day to see that it was prompting me to upgrade the size of my instance. The instance was hosting 4 low traffic wordpress sites on a micro instance, so fair enough, I went ahead and upgraded it to a small instance.

The system took my server offline for about 2 minutes, resized the instance, and then booted it back up. However now post reboot non of my sites are reachable giving me a dreaded ERR_CONNECTION_TIMED_OUT.

I'm gone through the apache2 error logs, but this is the only clue that in here which doesn't seem like something that should totally be bringing down the instance:

[Sun Jul 02 06:29:59.116350 2017] [mpm_prefork:notice] [pid 1854] AH00163: Apache/2.4.10 (Debian) configured -- res uming normal operations

[Sun Jul 02 06:29:59.116399 2017] [core:notice] [pid 1854] AH00094: Command line: '/usr/sbin/apache2'

[Sun Jul 02 20:54:19.098816 2017] [:error] [pid 17958] [client 179.219.113.226:60741] script '/var/www/argineconsul ting.com/public_html/command.php' not found or unable to stat

[Mon Jul 03 02:33:51.193230 2017] [mpm_prefork:notice] [pid 844] AH00163: Apache/2.4.10 (Debian) configured -- resu ming normal operations

[Mon Jul 03 02:33:51.225527 2017] [core:notice] [pid 844] AH00094: Command line: '/usr/sbin/apache2'

[Mon Jul 03 02:48:01.236769 2017] [mpm_prefork:notice] [pid 844] AH00169: caught SIGTERM, shutting down

[Mon Jul 03 02:48:02.309718 2017] [mpm_prefork:notice] [pid 1441] AH00163: Apache/2.4.10 (Debian) configured -- res uming normal operations

[Mon Jul 03 02:48:02.309788 2017] [core:notice] [pid 1441] AH00094: Command line: '/usr/sbin/apache2'

I've tried going back through the setup for my VPS to make sure everything is working there - nothing seems out of wack. Any thoughts appreciated.

0

I figured this out - apparently when you resize an instance on GCP it issues you a new IP address. I had to update Cloud DNS with the new IP addresses and everything worked fine. I think the resize process should have expressly called this out because I wasted a number of hours trying to figure out what was wrong. :-(

  • By default instances are assigned ephemeral IP addresses, which would get recalled during any instance restart. You can reserve a static IP address and assign it to an instance: cloud.google.com/compute/docs/… – Ilya Zakreuski Jul 4 '17 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.