4

I installed Debian 9 ("Stretch") in a virtual machine hosted on ESXi 6.5 The OS is up-to-date and nothing else has been installed but VMware tools.

Sometimes when I execute a command, the server will freeze and nothing can be done besides resetting the VM (the SSH server becomes unresponsive, all terminals are freezed, it doesn't show a KP or anything else)

I can reproduce the problem very easily: I just have to execute wget a couple of times and the OS will hang.

At first, I thought it could be a RAM problem. I used memtest86+ on the host and no problem was found. I also tried the debian package "memtester" which runs very well in the VM and doesn't make the OS freeze whatsoever.

/var/log/messages shows nothing special, but there's one line I don't understand:

Jul  3 13:05:57 myhost kernel: [   58.966715] TCP: ens192: Driver has suspect GRO implementation, TCP performance may be compromised.

What could be the problem and how can I debug the whole thing?

Config: 1 CPU / 4 cores - 32GB Ram - 64GB HDD

1
  • Same problem. It is driving me mad. Jan 30 '18 at 8:23
6

I had this exact scenario going on. Created a Debian 9 VM under ESXi 6.5 and it would freeze when running a few commands. Also, when I closed an SSH session, it would completely freeze and my only option was to reboot.

I fixed it by changing the network adapter type for this host from the default "VMXNET 3" to "E1000e".

0
2

If it is a VM, and you can change some parameters, try to set up another type of network adapter, as that looks network related.

Also, check also the dmesg output from time to time, even if it is working ok, as it may show other problems.

0

This seems related.

Anyway we also have stretch VMs running as guests under VMware, uname -a returns:

Linux sandbox1 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u2 (2017-06-26) 
x86_64 GNU/Linux

but sudo dmesg|grep ens192 is empty ...

0

I've had these problems as well and the solution for me was to upgrade the ESXi from 6.5.0-standard (build 4887370) to, in my case, a Dell customized image of version 6.5.0U1 (build 7388607).

0

I had this problem and checked the settings. I discovered that VMWare 15 Player defaulted to only giving the VM 512MB of RAM and 1 processor. I increased it to 4GB and 2 processors, and the VM now works with no freezing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.