0

I have an OpenVPN setup on a pfSense to give me access to the private network. Everything works fine, I can connect and ping the VMs on the private network no problem; but when I try to request a web page (or anything else really) the packet comes back via the VPN interface on the client and nothings happen.

Note that I can reach the gateway where pfSense is 192.168.50.1 but nothing else

Here's a screenshot from Wireshark :

enter image description here

The client network is 192.168.1.0/24

The VPN network is 172.16.0.0/24

The remote network is 192.168.50.0/24

Why do I get a response but then nothing happen ?

1 Answer 1

1

Alright, I found it and it works, took me a while but it's actually super simple.

I'm using Xenserver to host pfSense and the VMs, pfSense is connected to both the public network and the private isolated network created by xen (which the VMs run on).

Xenserver has a problem with TX checksum offloading and it is not handled properly. You will have to disable it in the pfSense interface and for all the xenserver interface that pfsense use.

For pfSense on the web gui; System > Advanced > Networking and check Disable hardware checksum offload then you'll have to reboot pfSense manually even if not prompted.

Here's how to disable TX Checksum offloading for Xenserver

1
  • same thing for proxmox / qemu. also check the firewall on the vmbr device of pfsense inside proxmox
    – JohnKiller
    Jan 8, 2021 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.