2

How can I disable firewall on ubuntu, or how can I check which ports are listening, and how can I add some new ports to be listened to?

Thank you

2

to see if the firewall is running

> sudo /sbin/iptables -L        
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         
> sudo /sbin/iptables -t nat -L
Chain PREROUTING (policy ACCEPT)
target     prot opt source               destination         

Chain POSTROUTING (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

if you see anything else in the output except default policies that read ACCEPT then you have a firewall on

1

Check which ports are listening:

netstat -tlunp

Ubuntu 9.04 doesn't have any firewall by default, did you enable any?

  • I'm not sure, I just can't open any https websites .. So my first guess is firewall? – c0mrade Nov 18 '09 at 15:59
  • I would say firewall is not likely to be your problem. You cannot access websites from that machine or run a web server in that machine? – pupeno Nov 18 '09 at 16:01
  • I'm trying to access the server machine from another machine.. not from the same machine if that is what you're implying – c0mrade Nov 18 '09 at 16:03
  • 1
    Sorry, can't follow, which machine is which? Can you name them or something? – pupeno Nov 18 '09 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.