The past few weeks I've been using a VM in azure for programming work. The VM is size Standard_A4_v2 (4 cores, 8 GB memory). Occasionally when trying to compile or preform some IO bound operation visual studio will just freeze up for minutes.

I see this question from 2014 suggesting adding multiple disks to try and speed things up. If I do that it seems like I'd have to install programs to different disks which isn't appealing.

Is there something else I could do that would help with disk IO performance without having to re-configure things?

Would upgrading to a different VM size give me much/any performance boost?

  • You chose the slowest performing vm series for yourself. You should try upgrading to a D series V2 or V3 and seeing if that makes a difference. But also, you're running on standard disks. If speed is truly essential, you can use a DS series, which supports OS and data disks being premium (SSD) which are significantly faster with guaranteed IOPS and throughput. – David Makogon Jul 5 '17 at 18:31
  • @DavidMakogon Thanks for the tip, I have a hard time parsing the specs. let me try to switch to one of these other VM types and see if things are noticeably better! – Andrew Walters Jul 5 '17 at 19:42
  • Yep, the A series are the oldest CPU on the platform and don't perform great. Even moving to Av2 would speed things up a bit, but your better looking at D or F. If you need gas disk as David says you should look at the DS – Sam Cogan Jul 10 '17 at 20:42

Upgrading VM size won't help much or anything at all if your issue is disk speed. To improve disk IO performance you need to setup Raid0 using multiple standard disks or use Premium Storage disks (SSD) in your VM.

Simply changing your VM from A to D will not convert your disk to SSD. You either need to copy your VM disk to a Storage Premium and redeploy it, or the easiest way, convert the disk to a managed disk and switch the performance tier to premium. Here's how to do it:

1) Convert single-instance VMs from Unmanaged Disks to Managed Disk


2) Convert Managed Disk from Standard to Premium


  • I tried running through the commands but get hung up trying to resize my VM to one that supports premium disks. I'm getting back the message "Failed to resize virtual machine 'X' to size 'Standard DS3 v2'. Error: Changing property 'osDisk.vhd' is not allowed. Would you have any ideas why I wouldn't be able to resize From D to DS tier ? – Andrew Walters Jul 11 '17 at 22:56
  • @AndrewWalters did you convert the disk from standard to premium managed disks? This needs to be done before resizing the VM – Bruno Faria Jul 12 '17 at 3:23
  • I put in azure support request when I was getting that error and I think maybe something was just messed up with my account. They took a look and had me re-run the same steps which actually worked a couple days later :-) – Andrew Walters Jul 13 '17 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.