I have had this problem on my laptop for months. If I connect from any other computers (local or remote) I have no problems with the same user.


Using Putty on Windows 10, I can connect to the server, put in username. As soon as I hit enter I see the prompt for the password but I also get a message:

"Network error. Software caused connection abort"

When I click ok the window goes inactive.

This happens on Putty. It also happens when trying to connect WinSCP on the same PC. If I try on my desktop there is no issue. This happens every single time I try to connect.


  • New IP address
  • Reinstall Putty and WinSCP
  • Reset Router
  • Checked server logs ("groot sshd[10669]: Connection reset by port 54916"

    That is the only line that comes up in the log when I try to connect.


I recently put in a Wifi access point in another location than our main one. I decided to try this and it worked. It must be something to do with the wifi router. I think it also happens when sending keys because I tried connecting to a different server and as soon as I clicked yes on confirming a new key the window went inactive with the same error.

EDIT 2: Event log drop

2017-07-05 15:53:58 Connecting to port 22
2017-07-05 15:53:58 We claim version: SSH-2.0-PuTTY_Release_0.69
2017-07-05 15:53:58 Server version: SSH-2.0-OpenSSH_7.2p2 Ubuntu-4ubuntu2.2
2017-07-05 15:53:58 Using SSH protocol version 2
2017-07-05 15:53:58 Doing ECDH key exchange with curve Curve25519 and hash SHA-256
2017-07-05 15:53:58 Server also has ssh-ed25519/ecdsa-sha2-nistp256 host keys, but we don't know any of them
2017-07-05 15:53:58 Host key fingerprint is:
2017-07-05 15:53:58 ssh-rsa 2048 b4:e3:25:2f:b5:01:1a:96:28:6d:c1:2c:e4:fd:7d:de
2017-07-05 15:53:58 Initialised AES-256 SDCTR client->server encryption
2017-07-05 15:53:58 Initialised HMAC-SHA-256 client->server MAC algorithm
2017-07-05 15:53:58 Initialised AES-256 SDCTR server->client encryption
2017-07-05 15:53:58 Initialised HMAC-SHA-256 server->client MAC algorithm
2017-07-05 15:54:13 Network error: Software caused connection abort
  • When you start PuTTY, make sure the "Close window on exit" option at the bottom of the configuration dialog is set to "Never". After you connect and get the error message, right-click on the PuTTY title bar, and in the menu that appears, choose Event Log. Click the Copy button, then edit your question and paste in the log. It will likely show the underlying cause of the disconnection. Commented Jul 5, 2017 at 19:49
  • @JamesSneeringer I added the log. Also so happy I found a work around with using a different access point. Commented Jul 5, 2017 at 19:58
  • Your access point is a true accesspoint in bridge mode, or its a router that double nat ?
    – yagmoth555
    Commented Jul 5, 2017 at 22:51

2 Answers 2


This is old but it turned out that my GS65 Killer wifi driver had settings to monitor bandwidth for gaming purposes. This was actually killing my connections. Turning this setting off fixed so many other weird network problems I was having


Also try setting in Putty for the profile you are defining,

Connection -> SSH -> Host Keys Manually configure host keys for this connection Host keys or fingerprints to accept In the "Add key" field, enter the fingerprint identified in the log. In your case ssh-rsa 2048 b4:e3:25:2f:b5:01:1a:96:28:6d:c1:2c:e4:fd:7d:de Click "Add key" and it should appear in the accepted list.

Test your connection.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .