1

Using squid3 -k parse I see this:

Processing: https_port 443 cert=myCA.pem
ERROR: 'https_port' requires --enable-ssl

How to enable ssl?

Output of squid3 -v

Squid Cache: Version 3.4.8 linux configure options: '--build=x86_64-linux-gnu' '--prefix=/usr' '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--sysconfdir=/etc' '--localstatedir=/var' '--libexecdir=${prefix}/lib/squid3' '--srcdir=.' '--disable-maintainer-mode' '--disable-dependency-tracking' '--disable-silent-rules' '--datadir=/usr/share/squid3' '--sysconfdir=/etc/squid3' '--mandir=/usr/share/man' '--enable-inline' '--disable-arch-native' '--enable-async-io=8' '--enable-storeio=ufs,aufs,diskd,rock' '--enable-removal-policies=lru,heap' '--enable-delay-pools' '--enable-cache-digests' '--enable-icap-client' '--enable-follow-x-forwarded-for' '--enable-auth-basic=DB,fake,getpwnam,LDAP,MSNT,MSNT-multi-domain,NCSA,NIS,PAM,POP3,RADIUS,SASL,SMB' '--enable-auth-digest=file,LDAP' '--enable-auth-negotiate=kerberos,wrapper' '--enable-auth-ntlm=fake,smb_lm' '--enable-external-acl-helpers=file_userip,kerberos_ldap_group,LDAP_group,session,SQL_session,unix_group,wbinfo_group' '--enable-url-rewrite-helpers=fake' '--enable-eui' '--enable-esi' '--enable-icmp' '--enable-zph-qos' '--enable-ecap' '--disable-translation' '--with-swapdir=/var/spool/squid3' '--with-logdir=/var/log/squid3' '--with-pidfile=/var/run/squid3.pid' '--with-filedescriptors=65536' '--with-large-files' '--with-default-user=proxy' '--enable-build-info= linux' '--enable-linux-netfilter' 'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2 -fPIE -fstack-protector-strong -Wformat -Werror=format-security -Wall' 'LDFLAGS=-fPIE -pie -Wl,-z,relro -Wl,-z,now' 'CPPFLAGS=-D_FORTIFY_SOURCE=2' 'CXXFLAGS=-g -O2 -fPIE -fstack-protector-strong -Wformat -Werror=format-security'

5
  • Which version? Which debian? Which....you get the drill. But there is a "bug" in squid3 for debian repos: bugs.launchpad.net/ubuntu/+source/squid3/+bug/16669 actually it just was disabled. Depends on your version...
    – Lenniey
    Jul 6 '17 at 7:58
  • squid Version 3.4.8. debian 8.5
    – yunqian
    Jul 6 '17 at 8:08
  • Add the output of squid3 -v
    – Lenniey
    Jul 6 '17 at 9:45
  • I put data in Answer
    – yunqian
    Jul 6 '17 at 11:06
  • @yunqian, please put that in your original question (you can edit your post) and not as an answer.
    – Diamond
    Jul 6 '17 at 11:17
1

Well, as shown in your squid3 -v output, you don't have the --enable-ssl flag in your squid compiled options. So no SSL for you, I'm afraid. Compile it with the --enable-ssl flag or use different methods, like SslBump.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.