0

A couple of days back I updated Apache on the webserver. Which seems to have broken accessing Phpmyadmin through server IP:

server.ip/phpmyadmin

Instead now when typing above the ip/phpmyadmin it redirects to the domain which is hosted on the server.

domain.com/phpmyadmin

It gives a 404 error obviously, since /var/html/www where the domain is pointed has no Phpmyadmin directory/resource.

I have tried the following, upto no avail:

sudo dpkg-reconfigure phpmyadmin

Checked the following directories for any reference to phpmyadmin redirection:

/etc/apache2
/etc/phpmyadmin

Any ideas?

  • Check your /etc/apache2/[sites- | conf-][enabled | available]/ directories and maybe /etc/apache2/conf.d/. Sounds like your upgrade killed the default page and uses the default vhosts. – Lenniey Jul 6 '17 at 13:38
0

PHPMyadmin was set to use SSL.

Using 'https' instead of 'http' resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.