4

After a system reboot, nfs-kernel-server was inactive. When I try to start I get

nfs-server.service: Job nfs-server.service/start failed with result 'dependency'.

which is echoed in journalctl -xe. I am using Ubuntu 16.04.2. Tried a reinstall, and received the same message.

The only flag I can see is that a

systemctl list-dependencies nfs-kernel-server

gives nfs-mountd.service as failed, while

systemctl list-dependencies nfs-mountd.service

shows nfs-server.service as failed.

Output of systemctl status:

nfs-server.service - NFS server and services
Loaded: loaded (/lib/systemd/system/nfs-server.service; enabled; 
vendor preset: enabled)
Active: inactive (dead)

while when I try to start the service (journalctl -f),

Failed to start NFS Mount Daemon
Dependency failed for NFS server and services.
nfs-server.service: Job nfs-server.service/start failed with result 
'dependency'.
  • What is the output of systemctl status nfs-server.service. Also use journalct -f in a shell as root and restart the nfs server in a second shell to watch what is happening during the start. – Thomas Jul 8 '17 at 10:40
  • There seems to be a detailed thread about this here: bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/1590799. I have added what worked for me there, systemctl add-wants multi-user.taget rpcbind.service but it seems to be a temporary fix. – scojo5 Jul 10 '17 at 14:22
0

Is your Ubuntu server a linux container (lxc) ?

If yes, you need to set something like explained here:

mount fstype=rpc_pipefs, mount fstype=nfsd,

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.