I've got a huge server (running Ubuntu Linux) which has got a 2TB raid sitting there just begging for me to backup to it.

I run netatalk to enable sharing via the AFP protocol to my Macs (all my client boxes are Macs pretty much) and had setup timemachine to use a shared drive on the server as it's destination.

Only trouble is it seems to be completely unreliable. I reguarly get problems where TimeMachine cannot finish the backup for one reason or another, and sometimes it seems to bring the whole server down (I know its a software rather than a hardware issue because the server is actually Ubuntu running under KVM and the KVM host is always still running).

So the question is has anyone had any success trying to do this? Does anyone know of any issues? Is there a better way to go about this? I know its a little vague but I was wondering if other users had experiences to share.

7 Answers 7


Here's an article I've stumbled upon that describes how to configure an Ubuntu box to be recognized as something to use with Time Machine by OSX. I've meant to hack this together on my Gentoo, but never got around to do, so I'm not making guarantees of whether it works or not.


In short, it's a 6-step guide on making OSX think that your Ubuntu computer is a XServe box, because it will be able to talk AFP and Bonjour.

  1. Modify and install Netatalk (Open Source AFP implementation)
  2. Configure Netatalk
  3. Configure shared volumes (and Time Machine volume)
  4. Install Avahi (Open Source Bonjour implementation)
  5. Configure Avahi and advertise services
  6. Configure TimeMachine

The transport doesn't matter (I do it over AFP to an airport extreme and SMB to a FreeBSD box (onto a raidz volume).

The key is enabling backups to unsupported volumes:

defaults write com.apple.systempreferences TMShowUnsupportedNetworkVolumes 1

This will make a mounted share available and create a sparse disk image atop it and allow you to back up to that.

  • I already had this set: I'm aware how to set it up, but it seems completely unreliable via AFP. I didn't know that SMB would work, I'll give it a go instead.
    – jkp
    Apr 30, 2009 at 17:52
  • It can be noted as well that you'll want to be running 10.5.6 or later - there are several changes in 10.5.6 that helped avoid corruption issues that also came out with Time Capsule's 7.4.1 firmware (for their server side but the client side changes help the OP)
    – Chealion
    May 12, 2009 at 16:57

I have had success with this, but not using AFP. With OSX macs, you're much better off using Samba and mounting the shares that way. I've been using that for quite a while with no ill effects.

  • Hey Jack: so TimeMachine will work against Samba drives? I thought it only liked AFP shares...
    – jkp
    Apr 30, 2009 at 14:24

jwz published a good article on the subject:

The universe tends toward maximum irony. Don't push it.


The two links above cover the prevailing issues with TimeMachine/AFP and remote clients. If you Google the various subject topics, there seems to be an increasing number of issues with AFP servers (running under netatalk) having issues with TimeMachine. I'm unaware of technical specifics, but I recently read that 10.5.7 did nothing to decrease these issues. When I first ran netatalk, 2.0.3 (with some patches), was the latest package. I experienced a wide range of issues with a small lan of Leopard (various patch level) machines, all running into various issues you can find sprinkled around on the netatalk-devel list. All of it is going into the 2.0.4 release that is not out yet, so you should check the trunk builds out. I had no problem compiling these on both an arm/i386 debian setup with the basic libraries to service Leopard clients.

I am unsure of this, but I recall someone asking about just moving the shares over to NFS/Samba, since it would offer the same service but not show up in the Finder browser (they disabled this in 10.5) and it is because TimeMachine uses a sparsebundle (form of dmg)/storage format that is specific to HFS+ and features like resource forks. They mentioned an instance where a TimeMachine restore was attempted on this setup and while it looked complete and TM reported no errors, the backup was fatally corrupt.

Basics for options: - use a separate system that backsup using a db format not specific to osx (many use sqlite or bdb). There are at least ten good programs on OSX you can find for this. - compile the latest trunk and test. I've yet to have any issues.


I've gone the way explained on kremalicious.com, as also reported by Hanrik Paul and had no problem up to now.

There is however a tools that may help you in understanding the quirks: Time Machine Error Logger.

There is also two further TM configuration tools I'd like to mention here, but I am afraid I need to come back here for this as soon as I'm back on the machine.

edit: There we go:


This has become dramatically easier.

Here is what my users experience: The user opens Time Machine preferences, clicks on select a disk, clicks on the host and then the disk (somewhere in there they are prompted for their ldap username and password), a home directory is created with the TimeMachine directory, and TimeMachine starts backing up to it and otherwise just works. Backups happen, if they need to restore either via Time Machine or by booting from an install disk (set language, then it's an option on the menue).

The one tricky part is getting a 2.2 netatalk build, I'm running 2.2 beta 4, and this makes things much easier.

My setup authenticates via ldap, the backup server runs Ubuntu 10.10, and I found a ppa for the beta.

Configure ldap.

Create a directory named TimeMachine in /etc/skel/ .

I recommend at this point logging in via ssh with a user account that has never logged in, just to make sure the above is all working right.

There has to be some correlation between the names, I just set everything to TimeMachine after realizing that, but I have not tried much else.

You have to set up avahi. That is easy enough, do note you need your MAC address and the name you are advertising. Key lines are these two txt-record's

Then set up netatalk. This is all I have in my netatalk file (well, and comments): name:TimeMachine :DEFAULT: options:upriv,usedots ~/TimeMachine "TimeMachine" options:tm

Best set of instructions and links I've found

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.