0

I'm using a router cascade out of two Fritzbox 7390 to implement a light version of a DMZ. Every Fritzbox has its own subnet. Fritzbox 1 (192.168.178.0/24) is connected to the Internet Service Provider. The Fritzbox 2 (192.168.188.0/24) uses the WAN Port to connect to Fritzbox 1. I have a samba and SSH server running in the 192.168.178.0 net. Accessing Samba in this network is working perfectly. In my 192.168.188.0 net I'm able to access the internet. I can also establish a SSH connection to the server in the other network. But samba on the same server is not reachable(Timeout). On my Fritbox 1 theres a static port sharing rule for SSH but not for Samba because the server should only be accessible by SSH over the internet. I tried to create a port forwarding rule on my Fritzbox 2 for Samba (139 UDP and 445 TCP) but the user interface on the FB2 denies creating the rules. Do I really need the port forwarding rules on FB2 because SSH on the same machine is also reachable without a rule?

0

Following this troubleshooting manual helped me a lot: https://www.samba.org/samba/docs/using_samba/ch12.html. SSH, Telnet and FTP was working charmingly except from samba. So browsing the web I discovered that the Fritzbox blocks netbios packets by default for security reasons what makes totally sense. In my scenario I had to disable this filter using the Fritzbox web interface. In previous versions altering the settings export file should worked as well (Not tested)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.