0

I am on Asterisk certified/13.13-cert3 and running into this problem.

I have a dialplan like so:

[extensions]
exten => _X.,1,noop
same => n,ConfBridge(123)

I have a conference profile with these options. Basically enabling DTMF passthrough so everyone in the conference can hear them.

[default_user]
type=user
dtmf_passthrough=yes

I have two SIP soft phones set up for testing SIP/user1 and SIP/user2

[user1]
type=friend
host=dynamic
username=user1
secret=password
context=extensions
host=dynamic
qualify=yes

[user2]
type=friend
username=user1
host=dynamic
secret=password
context=extensions
qualify=yes

I then join both these users to the conference.

Now with AMI, when I try to mute one party:

Action: MuteAudio
Channel: "SIP/user1-00000000"
Direction: "all"
State: "on"

I'm finding this works fine for spoken audio, but the DTMF digits are still being transmitted.

Is this a bug or by design? how can I prevent SIP/user1 from hearing anything including the DTMF?

Thanks for any help.

0

While this doesn't directly answer your question it could be the solution your looking for. By default conference members shouldn't hear the DTMF tones dialed by users at all, muted or not. They should just be absorbed by asterisk when received. Unless the 'dtmf_passthrough' option on the conference is enabled. So if you don't need the DTMF tones to be heard by others in ordinary circumstances you could check this value to make sure that it's disabled.

  • Hi Jesse, thanks for help. dtmf_passthrough is deliberately enabled in this situation. – prajo Jul 19 '17 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.