0

I'm trying to setup ubuntu 14.04 and Mariadb (5.5.56-MariaDB-1ubuntu0.14.04.1) with SSL. I've configured according to the instructions Here

My server reports this:

MariaDB [(none)]> SHOW VARIABLES LIKE '%ssl%';
+---------------+--------------------------------+
| Variable_name | Value                          |
+---------------+--------------------------------+
| have_openssl  | YES                            |
| have_ssl      | YES                            |
| ssl_ca        | /etc/mysql/ssl/ca-cert.pem     |
| ssl_capath    |                                |
| ssl_cert      | /etc/mysql/ssl/server-cert.pem |
| ssl_cipher    | DHE-RSA-AES256-SHA             |
| ssl_key       | /etc/mysql/ssl/server-key.pem  |
+---------------+--------------------------------+

When I connect from a client outfitted with the new certs, I get the message: SSL connection error: unknown error number

A tcpdump on the server shows the server cert being passed to the client then a few very short packets later, the server sends 08S01Bad handshake to the client.

Some searching turned up a mysql workbench error, but not sure it's related. Same error message though. Anyone know where else to look to fix this? The logs in /var/log/* or /var/log/mysql/* seem to be void of any error.

0

This fixed it. Looks like server and client certs cannot have the same CN: https://bugs.mysql.com/bug.php?id=68500

I was using an openssl.cnf with default values loaded so all certs used the same CN

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.