44

RDS server come up with 40 connection max, as in the following documentation
I am using Magento 1.9, and at some points, i reach the max number then website is out of service.
Do you have any recommended way to solve this issue?

From my understanding, if i have 2 web servers connection to an RDS server.. then I should have 2 RDS connections, not more.

  • 2
    "From my understanding, if i have 2 web servers connection to an RDS server.. then I should have 2 RDS connections, not more." That's an incorrect understanding. It's typically 1 connection per worker process or thread. – Michael - sqlbot Jul 16 '17 at 13:58
  • Thanks @Michael-sqlbot .. Yes i misunderstand this, but i wanted to make sure. But, why when we have 40 connection coming to RDS it refuses other connection and be unreachable till other connections are closed? – Alaa Badran Jul 17 '17 at 5:39
  • That's by design, from the max_connections parameter. For most workloads, you should be able to safely increase it, because it's a safely conservative default value... but you'll want to investigate the cause of those spikes. – Michael - sqlbot Jul 17 '17 at 8:46
64

AWS RDS max_connections limit variable is based on Instance type, so you can upgrade your RDS or make more replica.

The RDS types with max_connections limit:

  • t2.micro 66
  • t2.small 150
  • m3.medium 296
  • t2.medium 312
  • m3.large 609
  • t2.large 648
  • m4.large 648
  • m3.xlarge 1237
  • r3.large 1258
  • m4.xlarge 1320
  • m2.xlarge 1412
  • m3.2xlarge 2492
  • r3.xlarge 2540

Referring by max_connections at AWS RDS MySQL Instance Sizes in 2015

Update 2017-07

The current RDS MySQL max_connections setting is default by {DBInstanceClassMemory/12582880}, if you use t2.micro with 512MB RAM, the max_connections could be (512*1024*1024)/12582880 ~= 40, and so on.


Each Web server could have many connections to RDS, which depends on your SQL requests from Web server.

  • I know this, but when when reaching 40 connections, the server doesn't respond? Check this: drive.google.com/file/d/0B-_uggt0MBYOZElEMEItWDIwUEk/… – Alaa Badran Jul 17 '17 at 5:45
  • 1
    I check the RDS Parameter Groups, the max_connections is default by {DBInstanceClassMemory/12582880}, so when you use t2.micro with 512MB RAM, the max_connections could be (512*1024*1024)/12582880 = 40.69 which could explain your 40 max connections. – Nick Tsai Jul 17 '17 at 7:59
  • 2
    You could check the value by querying that RDS MySQL with command show variables like 'max_connections';. – Nick Tsai Jul 17 '17 at 14:00
  • 1
    You can create a new parameter group and change the value of max_connections to the value you want. This will be the new connection limit for your RDS instance. – backslashN Mar 26 at 8:46
  • 1
    This answer holds up in 2019. You can always check yourself by doing SHOW VARIABLES WHERE Variable_name='max_connections' – Dave Stein Jun 4 at 15:06
30

You can change the max_connections value by either updating the default parameter policy or create a new one - I'd suggest going with the latter.

  • Go to RDS
  • Parameter Groups
  • Create a new Parameter Group (AWS wil leave everything as default)
  • search for the max_connections value
  • Change the value to use
  • Go to RDS instance and modify
  • Select new Parameter group created and restart the instance or let AWS reboot it during next maintenance window

Hope this helps!

  • 2
    <3 this should be the accepted answer – bbozo Apr 5 '18 at 15:11
  • 2
    even though I set max_connections to 1000, rds still only allowed 100 max connections on a micro instance – Miguel Mota Apr 12 '18 at 19:14
1

While increasing the max connections on the server config may fix the problem, you should consider verifying your application configurations and implementations.

I'm not an expert on Magento, but as I recently had a similar issue on a project I was working on, I noticed that the default implementation of the framework I was using created a connection with every call to the database.

While that may not cause any problems to some, the moment you have more visitors or some tasks that are database intensive and can run on multiple connections, the best way to prevent the server crashing with "TOO MANY CONNECTIONS" error is to implement a database connection pool.

This prevents the application from creating more connections that the server can handle, and not crashing the application to the users. A connection pool would keep a queue for the requests to access the database until a connection becomes available so it can proceed with processing the users request.

Just keep in mind that the connection pool should be thread safe in a multi thread scenario.

1

Login to your RDS instance (using a MySQL client) and run the following query:

SHOW VARIABLES LIKE 'max_connections';
1

Actual info for Postgresql t3-instances (default.postgres10 parameter group):

  • db.t3.micro - 112 max_connections
  • db.t3.small - 225 max_connections
  • db.t3.medium - 450 max_connections
  • db.t3.large - 901 max_connections
  • db.t3.xlarge - 1802 max_connections
  • db.t3.2xlarge - 3604 max_connections

Its similar for default.postgres9 and default.postgres11

0

That's not 40 connections max, that is 40 RDS instances max. You are most likely only using 1 instance based on your description.

You can have thousands of connections to the RDS server because each time a session is opened with the database, that creates a new connection. You are probably running into performance constraints and should look into making the RDS instance larger.

  • Thanks @jason I have the following information: When reaching 40 connection, RDS doesn't respond till other connections close. We have r3.xlarge RDS instance. Here is a screenshot of this: drive.google.com/file/d/0B-_uggt0MBYOZElEMEItWDIwUEk/… We have idle CPU with high number of connections – Alaa Badran Jul 17 '17 at 5:41
  • This is connections, not other thing – Orlando Jan 6 '18 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.