0

I currently have a Synology NAS at my office that I wish to connect to remotely with SMB. This works perfectly fine on my MacBook, I use finder to connect with smb:\\<domainname>\<share>, but I cannot do the same on the Windows 10 machine. The network environment is exactly the same. I tried mapping a networking drive with \\<IP>\<share> and \\<domainname>\<share> but it fails to connect every time. Any suggestions on how to get it to work?

Thanks in advance,

  • Fails to connect? Do you get any messages/errors? Also, make sure you're using backslashes in the entire UNC path. You've still got forward slashes in your question and I'm unsure if that's a typo or if that's actually how you're trying to connect. – joeqwerty Jul 18 '17 at 0:56
  • It says "The folder does not appear to be valid. Please choose another." I have corrected my typos above. – Gundamire Jul 18 '17 at 3:44
  • Can you navigate to just the hostname? (i.e. do not go to the shared folder, just the IP address/hostname.) – Davidw Jul 18 '17 at 5:41
1

Not enough details provided, so many reasons can be behind this problem which looks to be related to the Windows machine. Try to verify these steps :

  1. Check if NetBIOS is active on the machine : Activate NetBIOS
  2. Check smb version : SMB version Check
  3. Check your firewall and settings related.
  4. Check the rights in the NAS server : the user you are connecting with in Windows has the rights to access that folder.

Note that smb/CIFS has many issues with Windows.

  • NetBIOS is not required to access a share. It is also a security problem and should not be enabled. – Greg Askew Jul 30 '18 at 11:41
0

You must use backslashes and not forwardslashes:

 \\<domainname>\share 
  • Oh sorry, that was a typo in my original original question, I’ll fix it now! – Gundamire Jul 18 '17 at 0:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.