1

I installed Docker on the latest Windows OS and got the following message "Hardware assisted virtualization and data execution protection must be enabled in the BIOS." Hyper V is definitely enabled. However, the Performance tab of the Task Manager tells me that virtualisation is disabled. How do I enable it?

2
2

Look into your BIOS settings.
Depending on the hardware, you need a different key or combination of keys to get into BIOS settings at system boot. While there look for virtualization support, and specifically Intel VT-d (I assume here you have an Intel CPU).
Saving and restarting into the OS should enable virtualization.

Edit: This article from RedHat provides perhaps a better explanation of above, see point 4.

0

I faced the same issue, when I was installing Docker Desktop on my Windows Machine, there is a simple solution to this issue:

  1. Go to system setup(BIOS Setup) when your computer starts booting
  2. Go to Device Configuration
  3. Find Virtualization and then click the checkbox to enable it
  4. Restart your Machine

If you are having Hp PC/Laptop then follow the following steps:

  1. Press ESC while Booting
  2. It will redirect you to main Setup menu
  3. Press F10 to go to BIOS Setup
  4. Find out Device Configuration option
  5. Search for Virtualization in it
  6. Check It and restart your Machine

For More Details: HP Customer Support - Knowledge Base

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.