0

I created two nodes on CentOS 7:

  • node1: 192.168.0.1
  • node2: 192.168.0.2

Installed such tools:

# yum install -y pacemaker corosync pcs crmsh

Also did load balancer with HAProxy.

After I did all the things well, I reboot node1 to test high availability. When node1 booted, from this way can only see one node:

# pcs status corosync

This can see two nodes:

# crm status

But the other one is UNCLEAN!

Stack: corosync
Current DC: node1 (version 1.1.15-11.el7_3.5-e174ec8) - partition WITHOUT quorum

2 nodes and 0 resources configured

Node node2: UNCLEAN (offline)
Online: [ node1 ]

No resources

From node2 to check status, also the another one is UNCLEAN!

Stack: corosync
Current DC: node2 (version 1.1.15-11.el7_3.5-e174ec8) - partition WITHOUT quorum

2 nodes and 0 resources configured

Node node1: UNCLEAN (offline)
Online: [ node2 ]

No resources

How to deal with it?


Addition

I did this:

# pcs property set stonith-enabled=false

The corosync config:

totem {
    version: 2
    secauth: off
    cluster_name: lbcluster
    transport: udpu
}

nodelist {
    node {
        ring0_addr: node1
        nodeid: 1
    }

    node {
        ring0_addr: node2
        nodeid: 2
    }
}

quorum {
    provider: corosync_votequorum
    two_node: 1
}

logging {
    to_logfile: yes
    logfile: /var/log/cluster/corosync.log
    to_syslog: yes
}
  • first of all, you need to share your cluster configuration with us, if you would like to find some that can help you – c4f4t0r Jul 18 '17 at 9:03
  • Add your pacemaker and corosync config. The nodes aren't communicating correctly. Do you have STONITH enabled? – Lenniey Jul 18 '17 at 9:03
  • @c4f4t0r I added corosync config to the question. – cloud_cloud Jul 18 '17 at 9:11
  • @Lenniey I have disabled that. Added the operation to the question. – cloud_cloud Jul 18 '17 at 9:12
  • please add the complete output of crm status – Lenniey Jul 18 '17 at 9:13
2

Let UDP 5404 and 5405 through the firewall; those are the ports that Corosync will want to use to communicate by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.