0

I did a standard WSUS installation, now I'm trying to do the post-installation, but it's kept failing, I'm the administrator of the machine, and I've tried to do the installation again with a domain administrator account, but the post installation keeps failing with these logs:

: 2017-07-18 11:58:00 Postinstall started
2017-07-18 11:58:01 Detected role services: Api, UI, WidDatabase, Services
2017-07-18 11:58:01 Start: LoadSettingsFromXml
2017-07-18 11:58:01 Start: GetConfigValue with filename=UpdateServices-Services.xml item=ContentLocal
2017-07-18 11:58:01 Value is true
2017-07-18 11:58:01 End: GetConfigValue
2017-07-18 11:58:01 Start: GetConfigValue with filename=UpdateServices-Services.xml item=ContentDirectory
2017-07-18 11:58:01 Value is D:\Updates
2017-07-18 11:58:01 End: GetConfigValue
2017-07-18 11:58:01 Content directory is D:\Updates
2017-07-18 11:58:01 Database roleservice is not installed
2017-07-18 11:58:01 End: LoadSettingsFromXml
Post install is starting
2017-07-18 11:58:01 Start: Run
2017-07-18 11:58:01 Fetching WsusAdministratorsSid from registry store
2017-07-18 11:58:01 Value is S-1-5-21-4086084134-1731516386-1660926666-1001
2017-07-18 11:58:01 Fetching WsusReportersSid from registry store
2017-07-18 11:58:01 Value is S-1-5-21-4086084134-1731516386-1660926666-1002
2017-07-18 11:59:02 Configuring content directory...
2017-07-18 11:59:02 Configuring groups...
2017-07-18 11:59:02 Starting group configuration for WSUS Administrators...
2017-07-18 11:59:02 Found group in regsitry, attempting to use it...
2017-07-18 11:59:05 Writing group to registry...
2017-07-18 11:59:05 Finished group creation
2017-07-18 11:59:05 Starting group configuration for WSUS Reporters...
2017-07-18 11:59:05 Found group in regsitry, attempting to use it...
2017-07-18 11:59:05 Writing group to registry...
2017-07-18 11:59:05 Finished group creation
2017-07-18 11:59:05 Configuring permissions...
2017-07-18 11:59:05 Fetching content directory...
2017-07-18 11:59:05 Fetching ContentDir from registry store
2017-07-18 11:59:05 Value is D:\Updates
2017-07-18 11:59:05 Fetching group SIDs...
2017-07-18 11:59:05 Fetching WsusAdministratorsSid from registry store
2017-07-18 11:59:05 Value is S-1-5-21-4086084134-1731516386-1660926666-1001
2017-07-18 11:59:05 Fetching WsusReportersSid from registry store
2017-07-18 11:59:05 Value is S-1-5-21-4086084134-1731516386-1660926666-1002
2017-07-18 11:59:05 Creating group principals...
2017-07-18 11:59:05 Granting directory permissions...
2017-07-18 11:59:06 Granting permissions on content directory...
2017-07-18 11:59:06 Granting registry permissions...
2017-07-18 11:59:06 System.Security.AccessControl.PrivilegeNotHeldException: The process does not possess the 'SeSecurityPrivilege' privilege which is required for this operation.
at System.Security.AccessControl.Win32.GetSecurityInfo(ResourceType resourceType, String name, SafeHandle handle, AccessControlSections accessControlSections, RawSecurityDescriptor& resultSd)
at System.Security.AccessControl.NativeObjectSecurity.CreateInternal(ResourceType resourceType, Boolean isContainer, String name, SafeHandle handle, AccessControlSections includeSections, Boolean createByName, ExceptionFromErrorCode exceptionFromErrorCode, Object exceptionContext)
at System.Security.AccessControl.NativeObjectSecurity..ctor(Boolean isContainer, ResourceType resourceType, SafeHandle handle, AccessControlSections includeSections, ExceptionFromErrorCode exceptionFromErrorCode, Object exceptionContext)
at System.Security.AccessControl.RegistrySecurity..ctor(SafeRegistryHandle hKey, String name, AccessControlSections includeSections)
at Microsoft.Win32.RegistryKey.GetAccessControl(AccessControlSections includeSections)
at Microsoft.UpdateServices.Administration.ConfigurePermissions.GrantRegistryPermissions(IdentityReference identity, RegistryRights registryRights)
at Microsoft.UpdateServices.Administration.ConfigurePermissions.GrantRegistryPermissions()
at Microsoft.UpdateServices.Administration.PostInstall.Run()
at Microsoft.UpdateServices.Administration.PostInstall.Execute(String[] arguments)
Fatal Error: The process does not possess the 'SeSecurityPrivilege' privilege which is required for this operation.

If anyone has elderly experienced a similar issue and could help...

1
  • have you executed this command in "run as administrator" context ?
    – Sorcha
    Commented Jul 18, 2017 at 11:40

3 Answers 3

2

That last log line tells you what the issue is - the account you're using to run the installer does not have all the permissions required to complete the install.

Fatal Error: The process does not possess the 'SeSecurityPrivilege' privilege which is required for this operation.

Based on where we see it fail (on the Granting registry permissions... step), I would suspect a GPO or something on your domain locking down registry access, but I've seen this error pop up for other product installs around the Manage auditing and Security log rights, so it's hard to say for sure what the exact problem is. I'd recommend running the installer again and monitoring the process with something like ProcessMonitor. That way you can determine exactly what file or registry key prompts the failure, and grant the appropriate permissions.

1

You should manually add an user account to the "Manage auditing and security log" in secpol.msc

1

As above: "You should manually add an user account to the "Manage auditing and security log" in secpol.msc"

Some auditing software I used required messing with a GPO that specified a domain user to this security policy. By default the policy contains "Administrators", I put domain admins in there and ran the post-installation process as a domain admin.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .