0

I've been working on a new solution recently which is basically a 2012 R2 RDS Farm. In a nutshell, the users RDP to the connection broker which in turn passes their connection out to one of the session hosts.

All was working fine until yesterday. There was a crash on one of the storage arrays and I ended up having to reboot everything.

Now that everything is back up, I log into the RDS server and instead of being able to see my collections and manage the deployment, I see this...

enter image description here

Now this has been working fine for a while now and I'm due to hand over to our customer for testing in the next couple of days... I could really do without having to rebuild this. Is there anything I can do to get my deployment details back?

  • 1
    Restore from backups if you have them. – Tim Brigham Jul 18 '17 at 12:03
  • I have backups of most of the VM's, but not all of them... which would I restore? – John Jul 18 '17 at 12:15
1

Is this the connection broker or the session host? If it's the connection broker, that sucks but isnt that bad to rebuild depending on your environment. If it is the rdsh, great! You dont need to rebuild the entire server, only need to remove what bit of role for remote desktop is left installed, reboot and then reinstall the role. You should be able to point it to the connect broker easily with powershell and it will be as good as new.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.