0

I want to install IONIC but I don't like Windows because sooner than later will be problems with some development tool or service that's not compatible.

Ironically I'm having problems installing IONIC on Debian too, but I think it's related that I'm running Debian inside VirtualBox... and that I'm trying to install IOINC on a shared folder in Windows.

Node, npm & IONIC are installed and working. The problem arises when I try to create an IONIC app "ionic start myApp tabs" inside a folder shared with Windows.

The folder where I want to install my IONIC app is a shared folder mounted on Debian and created in Windows. In fact I can create IONIC apps in other folders of the system, the only one that shows these errors is the shared folder.

I think it's not a permissions problem. I've tried all the installation steps as root and the same error appears. Also IONIC can write in the shared folder because there are many files inside, but for some reason the creation of the IONIC app never ends right.

I guess these last lines of the log could give someone a clue on what's happening and help me to fix it.

67177 verbose cwd /media/sf_IONIC-Shared/myApp3
67178 error Linux 4.9.0-3-amd64
67179 error argv "/usr/bin/nodejs" "/usr/bin/npm" "install"
67180 error node v6.11.1
67181 error npm  v3.10.10
67182 error path ../acorn/bin/acorn
67183 error code EROFS
67184 error errno -30
67185 error syscall symlink
67186 error rofs EROFS: read-only file system, symlink '../acorn/bin/acorn' -> '/media/sf_IONIC-Shared/myApp3/node_modules/.bin/acorn'
67187 error rofs This is most likely not a problem with npm itself
67187 error rofs and is related to the file system being read-only.
67187 error rofs
67187 error rofs Often virtualized file systems, or other file systems
67187 error rofs that don't support symlinks, give this error.
67188 verbose exit [ -30, true ]

Please help. Thanks.

PD: You can read the entire log in the link below

https://drive.google.com/open?id=0ByMd2Tsklj1pVnM3Ymx1ajhVV0k

  • What have you done to troubleshoot the obvious error? 67186 error rofs EROFS: read-only file system, symlink '../acorn/bin/acorn' -> '/media/sf_IONIC-Shared/myApp3/node_modules/.bin/acorn' – yoonix Jul 27 '17 at 17:44
  • @yoonix IONIC install was able to create directories and files. I can access those files in Debian and Windows.. and write them too. My configuration in the shared folder of VirtualBox is not read only. If there's an obvious way to fix it thanks beforehand. – Beto Aveiga Jul 27 '17 at 18:24
0

This error happened because IONIC uses NPM which uses symlinks which VirtualBox filesystem doesn't like (for security reasons I don't understand).

Luckily there's a fix... You can read the original answer here: https://github.com/npm/npm/issues/992#issuecomment-289935776

The solution is copied below anyway.

On the host machine (assuming Windows), but some variation of this will work in any OS: cd C:\Program Files\Oracle\VirtualBox

  1. Run the following command: VBoxManage setextradata VM_NAME VBoxInternal2/SharedFoldersEnableSymlinksCreate/SHARE_NAME 1 replacing VM_NAME with your Virtual Machine's name (if you don't know this, in VBox go to Machine > Settings > General > Basic > Name --- also replace SHARE_NAME with the name of your shared folder, if you don't remember this, go to Machine > Settings > Shared Folders.

  2. Restart your VM AND VirtualBox, but run it as administrator. On Windows hosts, just right click the icon for VirtualBox and select Run as Administrator.

PD: This should be useful also when using NPM, not only IONIC, with a mounted shared folder in VirtualBox.

0

Take care, the fix seem to work, but is a bit confusing: You have to actually setup the shared directory GUEST Name, aka. prefix

sf_SharedWithUbuntu

Example for my case:

@DELL_TTM MINGW64 /d/Program Files

./VBoxManage.exe setextradata "Ubuntu 16 LTS" VBoxInternal2/SharedFoldersEnableSymlinksCreate/sf_SharedWithUbuntu 1

And don't forget to check that this ** VBoxManager program does not silent fail ;)

./VBoxManage.exe getextradata "Ubuntu 16 LTS" enumerate

which return

Key: GUI/LastCloseAction, Value: PowerOff Key: GUI/LastGuestSizeHint, Value: 1920,954 Key: GUI/LastNormalWindowPosition, Value: 3840,27,1920,1053,max Key: GUI/RestrictedRuntimeDevicesMenuActions, Value: HardDrives Key: GUI/RestrictedRuntimeMachineMenuActions, Value: SaveState,PowerOff Key: GUI/ScaleFactor, Value: 1 Key: GUI/StatusBar/IndicatorOrder, Value: HardDisks,OpticalDisks,FloppyDisks,Network,USB,SharedFolders,Display,VideoCapture,Feat Key: VBoxInternal2/SharedFlodersEnableSymlinksCreate/SharedWithUbuntu, Value: 1 Key: VBoxInternal2/SharedFoldersEnableSymlinksCreate/SharedWithUbuntu, Value: 1 Key: VBoxInternal2/SharedFoldersEnableSymlinksCreate/sf_SharedWithUbuntu, Value: 1

Host: Windows 7 Guest Ubuntu 16 LTS VirtualBoxManager: Version 5.1.30 r118389 (Qt5.6.2)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.