0

I would like to update my Gitlab from version 8.12.7 ( installed from sources / MySQL version) to 9.X ( package version with PostgreSQL )

To do it, I installed a Gitlab-ce on the same version with PostgreSQL , did my backup as recommenced on the documentation, run the converter as recommended here

Then , I transfer the converted backup tar through SCP to the new server with packaged installation , but , when I run the

gitlab-rake gitlab:backup:restore

I've got the following errors :
tar: Unexpected EOF in archive
tar: rmtlseek not stopped at a record boundary
tar: Error is not recoverable: exiting now

Like if my tar was corrupt , but I can successfully unpack it on both servers after the convertion step. I saw rsync could cause a problem but md5sum are the same on both side...

Any help would be gladely appreciated ! Thanks for reading , have a good sysadmin day

  • Hi , a little update cause now I have news errors when I'm trying to restore the backup file. Restoring PostgreSQL database gitlabhq_production ... ERREUR: erreur de syntaxe sur ou près de « ` » LINE 1: DROP TABLE IF EXISTS abuse_reports; – KaAzZ Aug 3 '17 at 12:08
0

I finaly found an answer

I've followed this post

There are some differences with the official documentation that allowed me to fix my problems. Hope this can help some others...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.