-1

I have an esxi host that recently had some drives fail, so in the process of backing up the data on the host to recover it all to a new array I attached a 5TB Seagate Drive, Blanked it & created a new datastore on it and it was all happy and working in ESXi 6.5 and allowed me to copy all the vmdk files off the dead array to it using the datastore explorer.

The problem I now have is that, ESXi 6.5 has now been rebuilt on the same machine, The new raid array is set up and working and all I am trying to do it is the reverse, Attach drive using existing VMFS signature and copy the VMDK accross to the array however it will just not play ball,

ESXi will see the drive but wont let me mount it, I keep getting a scary message saying "This configuration will delete the current disk layout. All File systems and data will be permanently lost"

Obviously this is definitely something I DO NOT want to happen.

Few points to note:

  • This is the same machine just a rebuild of esxi, - Same controller same drivers,
  • I have attached some other 8TB Drives to this machine a few days ago and it all worked fine
  • I have tried the same drive on a different HBA in the same machine and it has the same effect.
  • I have tried a UEFI and a Legacy BIOS attachment to see if that made a difference

For some weird reason rather than one big gpt partition it is showing 2 x Legacy MBR PRIMARY partitions, 1 x 2GB and 1 x 4.55TB.

Any ideas? I have attached the screenshot below: http://imgur.com/a/DsDaz

  • Busy day so not got time right now to help but I suspect you need to resignature the datastore - google that word and also maybe take a look at this; codyhosterman.com/2016/11/… - be back later ok – Chopper3 Jul 28 '17 at 11:44
  • Many thanks for taking the time to reply, I will take a look at this now, Really appreciate you taking the time to reply and hope to hear from you later :D – cgtechuk Jul 29 '17 at 12:20
  • 1
    You sir are a genius and I am an idiot lol! Whilst it wasnt the re-signaturing that was the issue the link you provided sorted it out . I did a hex dump as recommended in the guide and as soon as i did it I seen the words which reminded me that this disk was mounted in FreeNAS and presented to ESXi and not mounted directly what an idiot but glad its fixed haha " |.........u...Thi| 00000030 73 20 69 73 20 61 20 46 72 65 65 4e 41 53 20 64 |s is a FreeNAS d| – cgtechuk Jul 29 '17 at 12:50
1

As Chopper3 link told me to do a hexdump I did one and it told me the following

|.........u...Thi| 00000030 73 20 69 73 20 61 20 46 72 65 65 4e 41 53 20 64 |s is a FreeNAS d| 00000040 61 74 61 20 64 69 73 6b 20 61 6e 64 20 63 61 6e |ata disk and can| 00000050 20 6e 6f 74 20 62 6f 6f 74 20 73 79 73 74 65 6d | not boot system| 00000060 2e 20 20 53 79 73 74 65 6d 20 68 61 6c 74 65 64 |. System halted| 00000070 2e 00 9d 6b bd 83 41 7f dc 11 be 0b 00 15 60 b8 |...k..A.......`.| 00000080 4f 0f 90 90 90 90 90 90 90 90 90 90 90 90 90 90 |O...............|

It then dawned on me that this disk was a FreeNAS disk presented to ESXi and no wonder I couldnt mount it!

  • Ha - crazy, glad you got there in the end anyway. – Chopper3 Jul 29 '17 at 14:19
  • Actually you could try to mount it as a Raw Device Mapping - you risk killing it but it should hopefully just mount and enable you to copy your data off - wouldn't run it like that for long though. – Chopper3 Jul 29 '17 at 14:20
  • 1
    Hi Thanks for your reply and help, In the end I installed a FreeNAS VM, Mounted the disk onto it via hardware passthrough and copied it all off via putty – cgtechuk Jul 30 '17 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.