0

I am experiencing an issue with multiple Windows Server 2012 (R2) Terminalservers in different domains at different sites. The problems occur on both, the R2-version and the non-R2-version.

Each customer has a domain with a Printserver (2012 (R2), 2008 (R2)) and one or more 2012 (R2) Terminalservers. The Printserver has multiple shared printers, that are deployed via GPO. We did not deploy the printers via right-clicking them and selecting "Deploy via group policy" (or whatever that's called) on the Printserver directly. Instead, we deploy the printers by configuring them in the group policy on the Domain Controller. The policy is set to deploy the printers based on the user's groups, so that each user gets the printers he needs. Also, based on the groups, the default printers are set.

Now, the printers are deployed and the users can see and use them - everythings fine. Except, sometimes, the users can still see the printers in some applications, but in others, they can't see them. Also, when this happens and there is an app where the printers can be seen, there is no default printer set - at least there is no green tick where it should be. You can try to set the printer as default printer, but the green tick is not shown and you cannot print on this printer. When restarting the spooler, sometimes everything's fine again. Sometimes, however, you have to delete the printer, restart the spooler, and add the printer, in order to be able to print again.

Interestingly, when the user cannot print on his default printer, some other printers are working. It's as if there is something wrong with the printer object, and restarting the spooler fixes this. There are times, where the default printer is working, but others are not.

We have already been looking for stuck print jobs - none. We have tried adding the printers locally without the Printserver - successfully, there are no more faults. Customers, that have multiple Terminalservers, report that this problem does not occur on all Terminalservers at once. Instead, only one server at the time is affected. The errors are sporadic and cannot be foreseen. We have tried updating the printer drivers - didn't work.

Now, it seems to me as if the Printserver is not part of the problem as this happens with all current versions of Windows.

Has anyone had this issue before or knows, what I could do?

0

The key point I read on your question is;

Except, sometimes, the users can still see the printers in some applications, but in others, they can't see them

That mean your login is done before all the GPO apply. As It mean the printer creation take longer and the printer list get some time to be full. Some application does not refresh the printer list when the application is open. Office app support that, but a lot of smaller app does not. The printer must be there before they start.

Some tip exist to help you out;

  • Thank you, this is actually part of the problem. I'll try this GPO. Another point is, that printers disappear after some time. It seems like the printer is just gone for the applications, and you cannot print on it. It is still shown in the system settings, but you cannot print. – SITGuy Aug 1 '17 at 18:59
  • Any ideas? We're still having this problem, and don't want to install all printers locally. – SITGuy Aug 6 '17 at 11:32
  • @SITGuy you could preinstall all printer drivers on the server – yagmoth555 Aug 6 '17 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.