1

I am new to google app engine. Recently I have been using the google cloud console to develop my own blog for a while. However, since last Sunday, I cannot connect to the google cloud shell. Whenever I try to connect to the cloud shell, an error message comes up saying that "Google Cloud Shell is temporarily unavailable. Try connecting in a few minutes."

I have tried to restart the shell and re-logout/login but neither of them works. I tried to start the cloud shell under another project but it didn't work either. I have also tried to login in other computers or using other network but still don't work. I have asked a few friends and it seems that I am the only one who have this issue. Here is a screenshot of the issue that I have:

error screenshot

Does anyone have experience of dealing with this kind of issue? I am really eager to solve this problem because all my code is stored on the cloud code editor which can only be opened when cloud shell is connected. Your help will be really appreciated!

3
  • I tried but wasn't able to reproduce the problem. It works just fine for me. I am thinking it could be a problem with your network configuration or a problem localized to a geographical region. If it is a problem with your network configuration we need to know what you changed. A packet capture may help as well. If the problem isn't on your end, you are probably better off contacting Google support. Including your IP address could likely help narrow down the location of the problem.
    – kasperd
    Jul 30 '17 at 9:41
  • @kasperd I have tried to connect to the shell on another computer which is connected to a different network but the same thing happened. So I don't think it's because my network configuration. One thing I would like to mention is that I registered another free trial using another google account and when I login using that account, I am able to connect to the cloud shell. So is it possible that there is certain configuration I need to do within my google account?
    – Kai
    Jul 31 '17 at 3:05
  • Were you able to solve this issue? If so please consider posting an answer, it would benefit the rest of the community. From your comments it did not seem to be related to networking or even your browser, instead related to your Google Account?
    – Carlos
    Jan 24 '18 at 16:27
1

There does seem to be intermittent/sporadic issues with Google Cloud shell today. I kept 'retrying' and it eventually got me connected into Cloud Shell after 20 or so retries. Probably an issue on Google's side.

2
  • Could you be more specific? Which regions are affected? I have tried several times and for me it worked every time. I got connected to a Cloud Shell machine in europe-west1.
    – kasperd
    Jul 30 '17 at 17:20
  • @alke2007 I am having this trouble for a week. And the weird thing is I can connect to the cloud shell using another google account. Is it possible that there is certain configuration I need to do within my google account to solve this issue?
    – Kai
    Jul 31 '17 at 3:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.