0

How are you guys?
I'm getting the following issue. I was trying to fix it of several ways but without success.
In our organization, to navigate through internet, you need to configure the proxy server.

I have installed Skype for Linux Beta (v5.3.0.1) and I'm getting the following message when I open it.

Sorry, we couldn't connect to Skype.
Please check your internet connection and try again.

When I check Debug Logs, I get the following message:

[Mon, 31 Jul 2017 11:24:12 GMT][INFO][AuthenticationManager] Redirect to login at login.live.com/oauth20_authorize.srf?client_id=00000000480BC46C&redirect_uri=h
ttps%3A%2F%2Flogin.live.com%2Foauth20_desktop.srf&scope=service%3A%3Alw.skype.com%3A%3AMBI_SSL&response_type=token&cobrandid=90010&locale=en-US&client_flight=hsu%2Chlm%
2Chld%2CReservedFlight33%2CReservedFlight67&psi=skype&uaid=5c02b3d4d7b7e468f7ef81d0cfbefafa&lw=1

[Mon, 31 Jul 2017 11:24:12 GMT][WARN]Failed loading page. [-102] ERR_CONNECTION_REFUSED. Url: login.live.com/oauth20_authorize.srf?client_id=00000000480BC46C&re
direct_uri=https%3A%2F%2Flogin.live.com%2Foauth20_desktop.srf&scope=service%3A%3Alw.skype.com%3A%3AMBI_SSL&response_type=token&cobrandid=90010&locale=en-US&client_fligh
t=hsu%2Chlm%2Chld%2CReservedFlight33%2CReservedFlight67&psi=skype&uaid=5c02b3d4d7b7e468f7ef81d0cfbefafa&lw=1

I have to remove https:// from the URLs because I'm new here. The weird thing is, that when skype starts, it seems to recognize the proxy (It is a assumption)

[Mon, 31 Jul 2017 11:24:11 GMT][INFO][EcsConfig] Downloading ECS Config

[Mon, 31 Jul 2017 11:24:11 GMT][INFO][HttpsRequest] [1c4925] Sending request to GET https://a.config.skype.com/config/v1/SkypeElectronWrapper/1427_5.3.0.1?ConfigOption=
release&clientId=5c02b3d4d7b7e468f7ef81d0cfbefafa, Proxy: true, Attempt: 1/1

In my home I don't need proxy and it works like a charm

I tried also modifing the starter script (http://xpo6.com/skype-for-linux-behind-a-proxy-server/), proxifing the skype with tsocks, but all without success.

Maybe someone here has the magic solution (I hope it).

Thanks in advance, and please, if you need further Information, I could provide it.

Regards

  • I too had the same issue. I found the solution on their official website. support.skype.com/en/faq/FA34656/… Read the last question in the "Questions about getting started" dropdown. I tried it in ubuntu 14.04 and it worked like a charm !!! Hope it works for you !!! – Rohith Reddy Sep 4 '17 at 16:13
1

I have found the solution! I have centos 7 with Mate Desktop.

Mate has the option to configure global proxy in System -> Preferences -> Internet and Network -> Network Proxy. I configured it and Skype works like a charm now!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.