19

On Windows 10, when a new VM is created, it has "Use automatic checkpoints" in Settings/Checkpoints turned on by default. If I recall correctly, this was a change that the Windows team made some months ago on Windows 10 Insider builds (it doesn't happen on Server).

Is there a way in the registry or through PowerShell or somewhere else to turn that off so it doesn't happen to my new VM's on Windows 10?

Hyper-V Checkpoint settings

18

From a helpful fellow commenting at https://blogs.technet.microsoft.com/virtualization/2017/04/20/making-it-easier-to-revert/:

Set-VM -Name MyVM -AutomaticCheckpointsEnabled $false

will tell Hyper-V on Windows 10 not to use automatic checkpoints for that virtual machine only. I'm still not aware of a way to tell the Windows 10 Hyper-V host not to set that option on new VM's, but at least we have a good workaround.

Note: As of August 2017, automatic checkpoints are used only on Windows 10 and not on Windows Server 2016, so this parameter doesn't exist on Windows Server 2016.

| improve this answer | |
  • 9
    I have no idea why this question was closed as off-topic. Apparently the administrators here feel that Windows 10 and Hyper-V don't exist in business environments, or that I'm automating the deployment of VM's as a fun hobby at home. Sigh. – Scott Sep 21 '17 at 18:37
  • 1
    no idea too... but as in some of my questions the same happened... and even worse when I reply to the guy who closed the question sometimes my comments are deleted... after a few times I just gave up,,, – ZEE Feb 14 '18 at 20:29
  • 1
    @Scott, very helpful, thanks. Shame the question was closed for such a trivial reason. – 93196.93 Oct 23 '18 at 8:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.