0

So I start from the very beginning: I have a Supermicro X8DT3 running with ESXi 5 which is a host for a VM (old hardware, just for test purposes). Since I'm quite a noob regarding all this, I wanted to train and learn. I installed the Supermicro IPMIView software for monitoring the sensors like FANs and temperature on a local dekstop PC (Win7). I also tried to get SNMPT Traps working which caused the main problem.. I've setup all the necessarry options in the Supermicro BIOS regarding the BMC (setting the IP, gateway and subnet) and everything worked fine. Yesterday I changed the gateway in the IPMIView software from 0.0.0.0 to the same IP of the server.. since then everything is broken. Somehow this change affected the variables in the Supermicro BIOS and now i cant connect to my IPMI host. Since I'm not a native english speaker, I try to explain it with my configuration as good as possible:

Settings BEFORE everything broke: IPMI IP: 192.168.0.97 Subnet: 255.255.255.0 Gateway: 0.0.0.0 All this made in the Supermicro BIOS in the IPMI menu (the MAC was already set).

After I accidently changed the gateway to the IP adress (dont ask why, it was a long day) nothing worked. So I decided to change the gateway in the BIOS back to 0.0.0.0.. this didnt help. I cant ping the .97 IP. So I decided to change the IP this morning to 192.168.0.197 - same result. No ping, no connection. All the other settings are like before. What did I do? What may have caused this issue? I hope I could explain this issue as good as possible!

Kind regards,

manji15

7
  • Is the machine you are connecting from in the same subnet as the IPMI address? (just because you didn't explicitly state it: is the network cable connected on the IPMI interface?) – Gerald Schneider Aug 10 '17 at 7:34
  • Yes, both have the 255.255.255.0 subnet. The network cable is connected, I've just checked it. – Kolle Aug 10 '17 at 7:40
  • I was referring to the 192.168.? part. – Gerald Schneider Aug 10 '17 at 7:41
  • Both have a 0, yes. /add: Maybe it helps if I mention that if i do a /nslookup with the OLD IPMI IP (192.168.0.97), I get the domain (although the .97 IP isnt entered in the Supermicro BIOS), but with the new one .197 nothing works. Do I maybe have to switch the server completely off for some time? – Kolle Aug 10 '17 at 7:42
  • Still the same issue. I set it to DHCP now.. lets see if that works (bad feeling though). – Kolle Aug 10 '17 at 9:40
0

Ok guys, I managed to restore my settings from yesterday - now everything is working great again! The reset of the IPMI was the right thing to do. I did it by shutting down the server and removing the power cables, waited for about 15 minutes and wow, it really worked! Thanks to all!

2
  • By the way, this post helped me as well: serverfault.com/questions/470720/… – Kolle Aug 10 '17 at 11:10
  • I somehow doubt that a power loss would reset the settings, but if helped you, I'm glad. Regarding your new question, you should post it as a new question. This is not a discussion board. – Gerald Schneider Aug 10 '17 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.