I'm having issues with a storage space I created on a Win10 machine. It's a parity array composed of three 4TB drives. I "had" to replace one drive after the array went offline. After replacing the drive the repair of the array got stuck 0.02% away from removing the old disk. Soon after the machine started crashing when Windows tried to mount the disk. I've tried different machines with no luck. I believe the array should work at least with the two original disks, but it doesn't. On Win10 it crashes the machine. On windows server 2016 it waits for 5-10 minutes and then shows the array on the interface, but if fails to bring it online or repair it.

I get this error:

Virtual disk {e61a9b66-53a8-4d62-ba54-3a1d4c4b9ba9} has failed a write operation to all its copies.

You can online the disk by using the following commands in PowerShell:

Get-VirtualDisk | ?{ $.ObjectId -Match "{e61a9b66-53a8-4d62-ba54-3a1d4c4b9ba9}" } | Get-Disk | Set-Disk -IsReadOnly $false
Get-VirtualDisk | ?{ $
.ObjectId -Match "{e61a9b66-53a8-4d62-ba54-3a1d4c4b9ba9}" } | Get-Disk | Set-Disk -IsOffline $false

I'm a bit lost. I believe the information is still there. All four drives (three original and the added one) report healthy when connected alone. The drive I took out is probably out of sync right now. But the other three should be sync up to 99.98% (where the rebuild got stuck).

Is there any third party software that could help me? Maybe a checkdisk on the physical disk? Thanks in advance for any help.

2 Answers 2


You can try checkdisk, but I don't think it will help. Also, you can take Recuva or something similar to restore the data, but the right choice here is to restore from backups and don't use standalone Storage Spaces for critical applications.

  • 1
    I was able to clone this drive using HDD Raw Copy Tool by HDDGuru. The cloning reported only 3 sectors not copied. I put the disk back in the array along the other one drive and it worked! I was able to copy all my information safely out of the SS. Oct 31, 2017 at 18:24
  • 1
    chkdsk won't help with ReFS though... Nov 5, 2017 at 13:58

I got a answer as far as I can tell in the last 5 days of testing.

Check if you have any task of shadow copy job on that affected volume. Delete these tasks. For me the issue seems to be fine so far. It might be a bug with parity volumes and shadow copies on that disk. For me it randomly was dead and offline once it tried to create a snapshot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.