0

I'm on a network where direct access to any IP address is blocked. Because of this, I cannot ssh to any machine whatsoever. How do I bypass this? No VPN is working, no proxy (again an IP), no SOCK5 (again needs SSH) is working. How do I bypass this?

Even when I ssh like: ssh root@mymachine.com it does not work because I think mymachine.com is first resolved to IP and then connected which is banned.

enter image description here

and ssh: (works fine on any other internet connection)

enter image description here

10
  • What is allowed then? – sebix Aug 13 '17 at 11:07
  • @sebix access to only domains directly. Like google is allowed only from google.com and not from 172.217.26.238 – mehulmpt Aug 13 '17 at 11:23
  • Your computer resolves the Domain to the IP, always. This is how intenet works. – sebix Aug 13 '17 at 11:24
  • @sebix I know, but they somehow block access if I directly access IP address. Maybe they detect if a request does not go through their DNS resolver then block it? – mehulmpt Aug 13 '17 at 11:25
  • 1
    Concerning your first screenshot: They probably intercept HTTP and then block any hostname with an IP. For the second: there are thousands of possible reasons... – sebix Aug 13 '17 at 11:52
1

If you don't have IP connectivity you won't be able to use any protocols that rely on it.

5
  • but access is allowed to only domains directly. Like google is allowed only from google.com and not from 172.217.26.238 – mehulmpt Aug 13 '17 at 11:23
  • It looks like a proxy server doing that filtering on web traffic. It's probably a different reason why you can't ssh out, that is probably not working because you don't have port 22 allowed outbound. – martin81 Aug 13 '17 at 11:51
  • i tried to setup ssh on different port but it still doesn't work – mehulmpt Aug 13 '17 at 15:43
  • To put it another way you are probably only permitted outbound access on port 80 and 443, and that traffic is being filtered. Have you thought about submitting a request for access to whoever manages the network? – martin81 Aug 13 '17 at 16:33
  • Take a look at corkscrew to tunnel through the HTP proxy. – wurtel Aug 17 '17 at 10:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.