This is kind of a long story, but we discovered that controller B had quit working some time ago. We bought a used replacement, and I swapped it out. But I got an error saying there was a mismatch between the controllers. At this point, I also got errors saying "Writeback Cache Forcibly Disabled" and "Insufficient Cache Backup Device Capacity" - but they were for controller A, which I had not touched.

I discovered that the replacement controller had an extra board in it, and after removing the extra board and reinserting the controller, the DS3524 was happy with it. But the cache errors remained. I thought maybe it was because the battery on the replacement controller needed to be charged, so I let it go overnight.

Now the battery in controller B is charged and has completed the learning cycle. But controller A is still having the cache errors. I ran some scripts I found to disable and re-enable caching, and that didn't fix it. I then tried doing a reset on the controller. That also didn't fix it. I guess I'll need to go in person (the DS3524 is at another location) and try removing the controller and reseating the SD card.

But it just seems really odd to me that these errors occurred on the controller that I didn't touch. Is there anything else I can try that doesn't require physical access?

I should also mention that the firmware level is I did see some information about a firmware bug that causes this problem, but it's for a lower version.

1 Answer 1


It ended up being a bad SD card, apparently. After trying everything recommended by the Support Guru and then just powering everything down and bringing it back up didn't work, I tried replacing the SD card. That fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.