I am spending the past 3 hours of finding ways to release Google Compute Engine API In-use IP addresses as I have 8/8 in use. I googled, read the manuals but there is no way of releasing it anywhere in the console. I am trying to setup a Rails app. When compiling it got stuck with errors as I didn't provide the correct socket for DB (which doesn't really matter here). When getting stuck I released with hitting Ctrl+C in my terminal and that I assume is the issue. - I am brand new to Google Cloud, hence I can only assume.

The error message:

ERROR: (gcloud.app.deploy) Error Response: [400] The following quotas were exceeded: IN_USE_ADDRESSES (quota: 8, used: 8 + needed: 2).

Here visualised in the console: enter image description here

When I click within the console on compute engines I am only being asked if I want to create one. There is no other option.

Any help would be appreciated! Thank you.


5 Answers 5


I can't take full credit for this answer - I just remembered this one - but a deployment to Google's cloud leaves the old deployment in place (and thus using an IP and your hard-earned money) indefinitely.

Deployments can be triggered with --stop-previous-version to prevent this behavior, and you can use list and stop to find and remove the old deployments so they no longer use resources.

  • 1
    Ran this one-liner to clean up my old deployments: gcloud app versions list | grep -v SERVING | awk '{print $2}' | tail -n +1 | xargs -I {} gcloud app versions delete {} May 1, 2018 at 6:34

I don't even have an app deployed, just a Kubernetes cluster, so none of the suggestions helped for me. I kept deleting the cluster then recreating.

Found this page that lists the external IPs in use, which seems to be the root of the problem. Should work no matter what the reason is for your used-up IP addresses: https://console.cloud.google.com/networking/addresses/list

For my case of load balancers being the problem: I deleted all my clusters and still saw addresses in use. Then I found this page that lets me delete the load balancer IP mappings: https://console.cloud.google.com/net-services/loadbalancing/advanced/forwardingRules/list Recreated the clusters and services, and everything works fine now.

I don't know why deleting the cluster didn't free the addresses this one time. Maybe because I cancelled in the middle of one cluster's creation.

  • 1
    Yes! Thanks so much--load balancers for me as well. I was very sloppy about my cluster/resource creation, so I'm guessing that was the cause. This should be the accepted answer since it's the most general solution. May 10, 2018 at 7:31
  • If I could only reproduce this, I'd submit a bug report because it does seem like a bug.
    – sudo
    May 10, 2018 at 20:28

I got the same error, but the reason was that my build was pointing to a wrong project(gcloud config list). I had configured cloud SQL in my code but it was in a different project then the app engine where I was trying to deploy. The error shown was exactly as mentioned in the above issue.


For this issue, while creating the VM do not provide the external IP -

  1. Click on Management, Security, Disks, Networking, Sole Tenancy
  2. Click on Network
  3. Click on Network Interface
  4. In External IP - give None

This worked for me


I had the problem on kubernetes when I wanted to add a new node. Solved like this:

  • kubectl get svc
  • Delete old services with kubectl delete svc [service-name]

Hope this helps anyone else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .