0

I'm having a few problems with a Hyper-V Host that I'm unable to remote desktop to a few days after a reboot.

I get the following error when trying to RDP.

Remote Desktop cannot verify the identity of the remote computer because there is a time or date difference between your computer and the remote computer. Make sure your computer's clock is set to the correct time, then try connecting again. If the problem occurs again, contact your network administrator or the owner of the remote computer.

I've checked the following.

  • I can RDP to the Hosts VM's without issue
  • Checked the system time & time zone against my laptop, and against the domain controller
  • It's using the correct DNS servers
  • I cant connect using the hostname or the fully qualified domain name [FQDN], but I can connect directly via it's IP address
  • The automated backups on the server are showing RPC call failures to the host VM's when trying to backup specific directories
  • I cannot connect from the Host through Hyper-V directly to the VM's running on the server
  • I've reset the computer account through Active Directory Users and Computers. No change.

When attempting to run the powershell command "Test-ComputerSecureChannel - Repair"

Test-ComputerSecureChannel : Cannot reset the secure channel password for the computer account in the domain. Operation failed with the following exception: The server is not operational.

The server responds for a few days following a reboot. But after that then it fails to connect with the same symptoms. It's a production server, so rebooting it every day is not an option.

Does anyone have any ideas as to what might be causing such an issue?

  • Is this a question? This doesn't look like a question. This looks like a statement. Yes, this is definitely a statement and not a question. – joeqwerty Aug 21 '17 at 11:53
  • @joeqwerty updated my questionable "question" with a question for you. – Joey Bob Aug 21 '17 at 12:46
  • Based on the error, it looks like a time-drift issue. – CIA Aug 22 '17 at 14:06
  • @CIA I checked the time settings between the DC and server they are both showing the same and in the same time zone. – Joey Bob Aug 22 '17 at 14:38
0

So after a bit of fighting with this the error being shown by the RDP window is nothing to do with time & date being wrong on either the target or host.

Digging a little deeper it appears that a Domains Certificate Authority (CA) had an expired certificate, and as such needed to be renewed. This resulted in the trust relationship between this server (and only this server for some reason) to fail.

As a result of this, all I needed to do was to "Reset" the computer account in Active Directory Users and Computers on the primary domain controller. Then renew the trust relationship (following a reboot) between the server and the DC.

Warning: Anyone trying this for themselves, verify you have a local administrator login for the machine you are resetting this on. When you renew the relationship you'll get this error when trying to log back in using AD credentials.

The trust relationship between this workstation and the primary domain failed

Logging on locally as an administrator, I ran up Powershell and used the following command

Reset-ComputerMachinePassword -Server <Name of Domain Controller> -Credential <Domain Admin Account>

This then prompted me for domain admin username / password. Then rebooted the server and all is working well again.

I'm now able to remote to the VM's on the host machine, and I'm able to RDP to the FQDN of the server.

Thanks for all those that tried to help with this one.

-1
  1. If you are running a standard environment, where runs the DHCP & DNS services on network, make sure that DNS services started properly. Its probably worth restarting the services regardless.

Open the DNS console and check to see if there is any host records in forward lookup zone. if not you have got an issue with computers registering their details in DNS. Ensure that it has been configured correctly.

Useful Commands i.ipconfig / flushdns ii.ipconfig /all iii.nslookup iv.ping v.netsh int ip reset C:\reset.log Completely reset the NIC, clearing cache and network settings.

2.Choose external network connection type on Hyper-v virtual network, So that you can connect VM's from the Hyper-v Host

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.