7

This is a new Windows 2016 server. We have three users on it and two of them are able to login without issue. The third one, no matter what we've tried (except rebooting; trying to avoid that) is not able to login. He keeps getting this error:

The task you are trying to do can't be completed because Remote Desktop Services is currently busy

I tried rwinsta to reset the session, resetting the user's password, running shutdown /l from a command prompt running under his credentials. Nothing worked. Any ideas?

rdp error

UPDATE Tried everything I knew to try. Nothing worked. Had to buckle down and reboot.

  • Is each user initiating the RDP from a different workstation? What is different about each workstation? What happens if problem user starts RDP from workstation of a working user? See this – Clayton Aug 23 '17 at 13:49
  • Trying to RDP from the same two workstations. There are three of us, two workstations, and this particular user cannot login from either workstation while me and the other guy can both login from either workstation. – blizz Aug 23 '17 at 14:35
  • Possible licensing limitation? Can he login while you both are logged out? – ErnieTheGeek Aug 23 '17 at 16:00
  • Definitely not licensing. Even if we are all logged out, he gets the same error. – blizz Aug 23 '17 at 16:18
  • Happens on a Win10 Pro machine too - can't even log in through local console anymore on that user. I'm so glad Windows is now stable and Enterprise grade and you don't have to reboot anymore to fix problems. – dualed Nov 12 '17 at 10:14
4

What worked for me finally was to logon as a different admin user and start Task Manager, switch to the Users tab, right-click the problem user and select "Connect".

2

I had this exact problem. When I got in with the one account that could connect, I found in the Users tab of Task Manager that there were four sessions with null usernames. When I ended the Windows Login Application task for each, the null entries disappeared and I was able to log in via RDS normally. It did not require a restart.

0

Just had the same issue. Interesting that it was only me. Here's my fix. Since the message said RDP service is busy. But there were no sessions open. I went backdoor into the server via "Computer Management" and restarted the RDP service. Worked like a charm!!!

protected by Community Jun 11 at 14:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.