0

I am running ESXi 6.5u1 on my server and I have a VM with a thin provision with a max size of 128gb and the VM is reporting having a used space of about 4gb but ESXi is provisioning more than 64gb to the virtual hard drive. I have tried defragging the disk and cloning it into a new thin provision but it is still using far too much space. du -h --max-depth=1 and df -h are both reporting about 3.5 gb of total used space yet ESXi reports more than 64 gb. Here are some screenshots of this:

du -h: https://i.stack.imgur.com/31At5.png df -h: https://i.stack.imgur.com/brJiL.png ESXi: https://i.stack.imgur.com/Tzkic.png

Another unrelated problem is that I am unable to remove the floppy drive on the VM, when I shut the machine down and remove it, it just comes back once I reopen the VM editor.

Here is a picture of the same stats on my DNS server, as you can see it is not having the same issue. Both VMs are version 13, and on the same datastore which is vmfs 6.

disk usage reported in ESXi: https://i.stack.imgur.com/GGDuc.png disk usage reported on OS: https://i.stack.imgur.com/YBO4U.png

The difference with the DNS server is much smaller and can be explained by snapshots and allocated RAM.

1 Answer 1

1

I tried this and it worked perfectly

http://www.virten.net/2014/11/howto-shrink-a-thin-provisioned-virtual-disk-vmdk/

Basically, you use DD to make a file full of zeros that is as large as how much free data you have left on the drive and you use vmkfstools -K on your vmdk file which deletes zeros and effectively shrinks the file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .