0

Impossible to install NVIDIA driver on CentOS release CentOS Linux release 7.3.1611 (Core), the package kmod-nvidia gives errors and kernel incompatibilities.

Usually installed with yum install kmod-nvidia -y

Current output:

sudo yum install kmod-nvidia Loaded plugins: nvidia Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.x86_64 0:384.59-2.el7_4.elrepo will be installed
--> Processing Dependency: nvidia-x11-drv = 384.59 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(reservation_object_add_excl_fence) = 0x0afefde4 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_vblank_init) = 0xd594e463 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_universal_plane_init) = 0x66bc7079 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_printk) = 0xf3207539 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_plane_cleanup) = 0x993b0648 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_object_property_set_value) = 0xda980fae for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_modeset_unlock_all) = 0x0e3b5f46 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_modeset_lock_all) = 0x4d82712c for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_mode_validate_size) = 0x59f75768 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_mode_set_name) = 0x68b96c96 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_mode_prune_invalid) = 0x0be80b87 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_mode_probed_add) = 0x3c7e12fa for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_mode_object_find) = 0xcd45520d for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_mode_create_dvi_i_properties) = 0x97b982aa for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_mode_create) = 0x0a488c2e for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_mode_connector_update_edid_property) = 0x85c884c2 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_mode_connector_list_update) = 0xf719e9fa for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_mode_connector_attach_encoder) = 0xc542c1b2 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_mode_config_init) = 0xc62e5245 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_mode_config_cleanup) = 0x373bd683 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_kms_helper_poll_init) = 0xc584cf3b for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_kms_helper_poll_fini) = 0xb54dc905 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_kms_helper_poll_disable) = 0x486dd196 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_kms_helper_hotplug_event) = 0xba22491c for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_helper_mode_fill_fb_struct) = 0xb62aeac2 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_helper_hpd_irq_event) = 0xdef9ef66 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_gem_private_object_init) = 0xdfd2d95f for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_gem_prime_handle_to_fd) = 0xec097b40 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_gem_prime_export) = 0x87fc4b9b for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_gem_object_unreference_unlocked) = 0xe40a4bd7 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_gem_object_unreference) = 0xdc0d14b6 for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64
--> Processing Dependency: kernel(drm_gem_object_release) = 0xe2f2760b for package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64

...

Error: Package: kmod-nvidia-384.59-2.el7_4.elrepo.x86_64 (elrepo)
           Requires: kernel(drm_atomic_helper_set_config) = 0xe20392ec
           Installed: kernel-3.10.0-514.el7.x86_64 (@anaconda)
               kernel(drm_atomic_helper_set_config) = 0xb9ded30c
           Installed: kernel-3.10.0-514.26.2.el7.x86_64 (@updates)
               kernel(drm_atomic_helper_set_config) = 0xb9ded30c
           Available: kernel-3.10.0-514.2.2.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0xb9ded30c
           Available: kernel-3.10.0-514.6.1.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0xb9ded30c
           Available: kernel-3.10.0-514.6.2.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0xb9ded30c
           Available: kernel-3.10.0-514.10.2.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0xb9ded30c
           Available: kernel-3.10.0-514.16.1.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0xb9ded30c
           Available: kernel-3.10.0-514.21.1.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0xb9ded30c
           Available: kernel-3.10.0-514.21.2.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0xb9ded30c
           Available: kernel-3.10.0-514.26.1.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0xb9ded30c
           Available: kernel-debug-3.10.0-514.el7.x86_64 (base)
               kernel(drm_atomic_helper_set_config) = 0x0a284bbd
           Available: kernel-debug-3.10.0-514.2.2.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0x0a284bbd
           Available: kernel-debug-3.10.0-514.6.1.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0x0a284bbd
           Available: kernel-debug-3.10.0-514.6.2.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0x0a284bbd
           Available: kernel-debug-3.10.0-514.10.2.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0x0a284bbd
           Available: kernel-debug-3.10.0-514.16.1.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0x0a284bbd
           Available: kernel-debug-3.10.0-514.21.1.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0x0a284bbd
           Available: kernel-debug-3.10.0-514.21.2.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0x0a284bbd
           Available: kernel-debug-3.10.0-514.26.1.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0x0a284bbd
           Available: kernel-debug-3.10.0-514.26.2.el7.x86_64 (updates)
               kernel(drm_atomic_helper_set_config) = 0x0a284bbd
 You could try using --skip-broken to work around the problem
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
ipa-client-4.4.0-14.el7.centos.7.x86_64 has installed conflicts freeipa-client: ipa-client-4.4.0-14.el7.centos.7.x86_64
ipa-client-common-4.4.0-14.el7.centos.7.noarch has installed conflicts freeipa-client-common: ipa-client-common-4.4.0-14.el7.centos.7.noarch
ipa-common-4.4.0-14.el7.centos.7.noarch has installed conflicts freeipa-common: ipa-common-4.4.0-14.el7.centos.7.noarch
1
  • same situation with kmod-hfsplus package... – Kevin Lemaire Sep 12 '17 at 10:07
0

Solved by checking the different versions available:

sudo yum --enablerepo=elrepo --showduplicates list kmod-nvidia
Loaded plugins: nvidia
Available Packages
kmod-nvidia.x86_64 367.57-1.el7.elrepo elrepo
kmod-nvidia.x86_64 367.57-2.el7.elrepo elrepo
kmod-nvidia.x86_64 367.57-3.el7.elrepo elrepo
kmod-nvidia.x86_64 375.66-1.el7.elrepo elrepo
kmod-nvidia.x86_64 384.59-1.el7.elrepo elrepo
kmod-nvidia.x86_64 384.59-2.el7_4.elrepo elrepo

Then, install the correct version for the right release, CentOS is still in EL7_3:

sudo yum install kmod-nvidia-384.59-1.el7.elrepo -y

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.