1

I have a Cisco SG300-10SFP switch which I purchased just 6 months ago. I had intended to use it as a hub for a fiber network on our premises. It has 8 SFP ports and two Ethernet ports (all 1000M). I planned on using the two Ethernet ports in a LAGG to connect to my main switch. The SFP ports (which are running fiber) are working fine at 1000M full. However, the two Ethernet ports won't autonegotiate any higher than 100M at half duplex. I've tried different cables, different equipment and have narrowed it down to the switch. I even tried a laptop with a 3in cable. Both ports began having this problem at the same time which tells me its probably a setting and not necessarily a hardware issue. I even factory reset the router with no luck. I don't usually ask on forums unless I've exhausted all other options. Any help would be appreciated.

1
  • What are you using for the transceivers? – CIA Aug 25 '17 at 16:33
0

Try setting the speed and duplex manually.

From interface config mode the commands should be

Speed 1000

Duplex full

0

Maybe additional turn auto-negotiate off:

auto-negotiation off

If it does not work, show us the switchport config.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.