0

I have configured as forwarder for a domain.

zone "myself.abc.com" in {  
    type forward;
    forward first;
    forwarders {
    10.10.20.10 port 53;
    };
    forward-source {
    169.254.65.18;
    };
};

I am trying to have a configuration along with this for backup i.e. if my forwarder dint respond i can create a local zone file and provide some backup IP which DNS server doesn't send.

Option 1 - Which i have tried, using

zone "abc.com" in {
        type master;
        file "sample.zone";
};

It isn't working as it always start using sample.zone and never goes to forwarder.

Can anyone provide the solution for this, much appreciated your response :)

1

That's because BIND now believes it's authoritative for the domain i.e. type master;. It's normal.

If the domain is your own, the correct way to achieve the same outcome would be configuring your local BIND as a secondary name server (type slave;) and abandon both master and forward:

zone "example.com" {
    type slave; 
    file "example.zone"; 
    masters { 
        198.51.100.100; 
    }; 
};

In this scenario you should have power over the configuration of the primary authoritative name server in order to allow zone transfers from your local network. Example of the resulting configuration on the authoritative name server configured as type master; for the domain:

allow-transfer { other_ns; };

acl other_ns {
    192.0.2.100;          // the current secondary name server(s)
    203.0.113.80;         // IP of your local network
};

(Here, all the IP addresses are examples from the RFC 5737 TEST-NETs. Replace with your own.)

  • I have tried this but dns server is not responding correct DNS 88 Standard query 0x0a64 SOA myself.abc.com DNS 147 Standard query response 0x0a64 When i configure it like the way i shown in question it works fine. DNS 88 Standard query 0x0a08 A telstra.lab.iot DNS 152 Standard query response 0x0a08 A 172.28.141.120 A 172.28.141.190 Though my requirement is to use forwarder as I can provide an option for "forward-source", which I required. – user3553856 Sep 4 '17 at 13:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.