1

I am testing deployment of asp.net core 1.1 projects. I have two projects in the solution client and the identity server 4.

I have succeeded deploying the client app and I can browse externally.

After that I deployed the Identity Server. And this comes up with the error

HTTP Error 502.5

And when I check the event log it has the error

Application 'MACHINE/WEBROOT/APPHOST/IDENTITYSERVER' with physical root 'C:\inetpub\IdentityServer\' failed to start process with commandline 'C:\Program Files\dotnet .\IdentityServer.dll', ErrorCode = '0x80070002 : 0.

I initially had this error when deploying the first one so I went through this post

https://stackoverflow.com/questions/38624453/asp-net-core-1-0-on-iis-error-502-5

and followed all the steps, including installing the hosting packages and so on.

I tried to check the log by enabling the log in the web.config as well but the process will create an empty log file every time I tried to browse.

Both of them are using asp.net core 1.1

I think the only major different in terms of resource usage is, Identity server 4 uses SQL server. Other than that I cannot think of anything different.

In the IIS app pool settings both use ApplicationPoolIdentity, set to use No Managed Code for .net clr version.

For both of the applications I have modified the launchpath of the web.config file from "dotnet" to "C:\Program Files\dotnet"

Both project files are set to produce

I am running this on Google Could Compute Engine, Windows 2012, just in case this might make any difference.

I really hope someone can shed some light on this.

Appreciate all the help in advance.

I am posting this on serverfault because it seems to be a better fit, but if I am wrong please let me know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.